Invisible/Fading Meshes in mournhold sewers

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
CloneTwo
Posts: 2
Joined: 04 May 2019, 06:07

Invisible/Fading Meshes in mournhold sewers

Post by CloneTwo » 04 May 2019, 06:22

In the mournhold sewers, certain meshes seem to dissapear/not load, fade away before popping back in, not have any water despite being below water level, or having bright lighting in dark areas. This is really annoying and i don't know what could be causing it. The only mods that might have an impact are Patch for Purists, Morrowind Optimization Patch, Correct Meshes, and Project Atlas and the openmw log doesn't seem to have anything out of the ordinary so i don't know what could be causing this.
Image
Image
Image

User avatar
AnyOldName3
Posts: 1562
Joined: 26 Nov 2015, 03:25

Re: Invisible/Fading Meshes in mournhold sewers

Post by AnyOldName3 » 04 May 2019, 14:43

Does it change if you enable force shaders? I've seen a similar issue where someone was using Intel integrated graphics, and the driver was getting confused by fixed-function stuff.
AnyOldName3, Master of Shadows

User avatar
akortunov
Posts: 621
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: Invisible/Fading Meshes in mournhold sewers

Post by akortunov » 04 May 2019, 15:00

Bisect shows that the issue is in the Animation::setAlpha() (presumably a data race during transparency update for creatures).
PR #2355 seems to fix this issue for me.

CloneTwo
Posts: 2
Joined: 04 May 2019, 06:07

Re: Invisible/Fading Meshes in mournhold sewers

Post by CloneTwo » 04 May 2019, 15:32

Force shaders was enabled when i made those screenshots, not sure if disabling will make a difference though

User avatar
AnyOldName3
Posts: 1562
Joined: 26 Nov 2015, 03:25

Re: Invisible/Fading Meshes in mournhold sewers

Post by AnyOldName3 » 04 May 2019, 16:36

I've given it an LGTM, so as there are symptoms of it not being merged, I'm going to merge it if no one objects soon.
AnyOldName3, Master of Shadows

User avatar
akortunov
Posts: 621
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation

Re: Invisible/Fading Meshes in mournhold sewers

Post by akortunov » 05 May 2019, 05:30

Check the latest nightly build - this issue should be fixed.

Post Reply