How to import .osgt file into OpenMW-CS

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: How to import .osgt file into OpenMW-CS

Post by scrawl » 14 May 2016, 11:55

The cube shows a slight brown colour which i've not 'set' anywhere in blender, and in blender the cube is grey without the texture on so i'm wondering if that colour is being picked up from the texture and being applied in the engine somehow?
Probably because the cube has no UV map. You'll need to unwrap it in blender.

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: How to import .osgt file into OpenMW-CS

Post by openmwfan27 » 14 May 2016, 12:24

I've tried UV Mapping it although i'm not sure if it's right, this is what i can see in-game, in blender and the osg export settings i'm using, i've also tried exporting it without that ring thing to see if that helps but no luck:

http://imgur.com/a/MP4tQ

Lamoot
Posts: 82
Joined: 22 Apr 2016, 12:03

Re: How to import .osgt file into OpenMW-CS

Post by Lamoot » 14 May 2016, 14:08

openmwfan27, could you post the .blend file as well as any textures you're using?
http://www.pasteall.org/blend/

I went through the exporting process thoroughly and found many ways in which you can make your material look odd and it'll be easier to inspect it with a .blend file.

User avatar
openmwfan27
Posts: 113
Joined: 23 Apr 2015, 22:11

Re: How to import .osgt file into OpenMW-CS

Post by openmwfan27 » 14 May 2016, 14:26

Lamoot wrote:openmwfan27, could you post the .blend file as well as any textures you're using?
scrawl wrote:Probably because the cube has no UV map. You'll need to unwrap it in blender.
It turned out to be an issue with the UV Mapping, i scraped it and re-did it from scratch following a tutorial on youtube, exported it and the .png texture worked, i changed the filename in the .osgt to the .dds texture that was causing the CTD before and that works fine now too, including the normal and specualar maps :D

Not sure what i did wrong the first time, though.

These are the results: http://imgur.com/a/PTig9

In OpenMW-CS how do you get the move x,y,z arrows to come up and is it possible to rotate items in the 0.39 release via the scene view? So far i've been editing the x,y,z co-ords manually via the instances panel which is really awkward unless you're fine-tuning the position.

Post Reply