Page 1 of 1

Altmer can't use (some) stairs

Posted: 10 May 2015, 13:36
by DocClox
Hey all! Hearing good things about this project, thought I'd give it a try.

So, in the interests of doing something different, I thought I'd create a female Altmer mage. Tried to get to the cellar in the Seyda Neen Custom house, and she can't get down the stairs. He's apparent tall enough that her head collides with the roof of the staircase. If I toggle clipping off then the problem goes away.

Same thing happened trying to get downstairs at Balmora Mage's Guild.

It's possible that the actor is floating a tad above the ground. The camera seems to be higher than I'd expect. I'd put that down to the fact that Altmer are tall, except a dark elf character seemed to have a higher POV than I expected.

Other than that, stunningly good work.

Re: Altmer can't use (some) stairs

Posted: 10 May 2015, 14:38
by Tinker
A known problem, see, perhaps you could add some info that would help track it down.

Re: Altmer can't use (some) stairs

Posted: 10 May 2015, 17:33
by sjek
what can think of there's at least three possibilities

1. atmospheric sound effect is activated which places activator to move in pc position via script and couses someway floating

2. player collision shapes interact with the slope of the stairs (actually a slope with plane added in mages guild stop of the stairs as rootcollisionnode shape) and 2116

capsuleshape collision is in osg port

3. players are actually floating

Re: Altmer can't use (some) stairs

Posted: 10 May 2015, 22:44
by DocClox
Well, I tried again with just a quick start mod loaded and there wasn't a problem. So it's definitely mod related. I inherited the profile from an MGSO modifed game, plus a handful of extras, so there are dozens of possible culprits.

It's had to be sure about the floating issue (is there a TFC equivalent in MW/OpenMW?) but playing around with the vanity camera it looked like the actor's feet were on the ground. Of course for that to mean anything, I need to do the same thing with my full mod list.

My gut feeling though is that the ambient sound emitter is the likely culprit. It's getting a bit late tonight, but I'll dig a bit deeper tomorrow. I'll check the floating hypothesis with a full mod list, and then try adding sound mods until something breaks.

Anything else I can do, let me know. (I'd post my mod list but it's probably more useful if I can narrow it down a little first)

Re: Altmer can't use (some) stairs

Posted: 11 May 2015, 08:34
by Tinker
There is a known bug with widows glow mod changing the meshes of some windows and causing similar problems though usually for all players.

Re: Altmer can't use (some) stairs

Posted: 29 May 2015, 21:32
by PaulR
I have this problem in 0.35.1 in two places in Balmora:

1 Descending the stairs in one of the guard towers near the Manor houses (the righthand one when looking towards Caius's)

2 Leaving the first floor door from dura gra-bol's house and descending the stairs

In the first one I can get through the door by sneaking - once I've done that I can go up/down without hindrance, but in the second one I can't get under the archway at the bottom of the stairs whatever I try.

This is on Linux Mint 17. Just noticed 0.36 is out, I'll try the stairs problem using that.