Performance question

General discussion regarding the OpenMW project.
For technical support, please use the Support subforum.
Post Reply
ElderScrollsFan
Posts: 2
Joined: 27 May 2014, 10:52

Performance question

Post by ElderScrollsFan » 27 May 2014, 11:09

Hi guys I have a few questions regarding performance in version 0.29.0.
I tried every setting to get better fps but I'm always stuck from 10-15fps in exteriors, even when i turn everything off such as water effects and shadows my fps is in the mid 20s :( . In interiors I get from 60-80fps without v-sync and a constant 60fps with it enabled. I use MSAA 2x but I also tried disabling it and I also tried fulscreen and windowed. I don't think performace should be this low on a mid range pc I know you're still in the process of optimizing but I would just like to know if anyone is expiriencing the same issue?

My pc specs:
XFX AMD HD7850 2GB ( Latest drivers )
8gb ram
FX 4100 4.6ghz
Windows 7 64bit

Btw I love your project and I appreciate everything you're doing for the community and keep up the good work!! :mrgreen:

User avatar
lysol
Posts: 1487
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Performance question

Post by lysol » 27 May 2014, 12:37

Everybody has the same issue. The engine simply isn't optimised yet. Optimising is one of the last things you do as I've understood. Since version 1.0 gets closer and closer, we'll hopefully see better performance in a not too distant future.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
psi29a
Posts: 5050
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Performance question

Post by psi29a » 27 May 2014, 13:09

Fun fact... scrawl and zini followed the rabbit hole down the path while fixing a bug (growing size as game time increases) and for the save game feature. As a result, the filesize is less of a problem and we now have decreased cell loading times (33%)!
viewtopic.php?f=6&t=2188&hilit=save+game#p24586

Things will only get better with time. Patience is key.

ElderScrollsFan
Posts: 2
Joined: 27 May 2014, 10:52

Re: Performance question

Post by ElderScrollsFan » 27 May 2014, 13:55

Thank you for the quick response! :D


Post Reply