trouble with installing - boost::filesystem::path codecvt to wstring: error

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 17 Mar 2020, 06:09

my user name is just english characters. I assume that english characters are necessarily ascii characters? I also have a C drive. Putting the openmw folder on the C drive doesn't fix it.

squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 17 Mar 2020, 06:20

putting the Data Files folder on the C drive doesn't fix it

squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 17 Mar 2020, 06:34

if I can't get it to work on this computer I can probably get it to work on my other computer.

squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 17 Mar 2020, 18:22

it works on my other computer

squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 19 Mar 2020, 04:31

I've used https://wiki.openmw.org/index.php?title ... ripted_way to build it and put cout << "something" in some places and stuff to find which line is causing the problem. It seems to me that it is the line
FixedPathType mFixedPath;
in configurationmanager.hpp which is causing the error message.

User avatar
AnyOldName3
Posts: 1729
Joined: 26 Nov 2015, 03:25

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by AnyOldName3 » 19 Mar 2020, 14:17

https://gitlab.com/OpenMW/openmw/-/blob ... er.hpp#L57 is the link.

It won't be the problem, though, as it's just a member declaration and doesn't run any code.
AnyOldName3, Master of Shadows

squirrelly
Posts: 12
Joined: 16 Mar 2020, 20:39

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by squirrelly » 19 Mar 2020, 22:36

Fixed by uninstalling the game and reinstalling it.

User avatar
AnyOldName3
Posts: 1729
Joined: 26 Nov 2015, 03:25

Re: trouble with installing - boost::filesystem::path codecvt to wstring: error

Post by AnyOldName3 » 19 Mar 2020, 23:13

Huh.
AnyOldName3, Master of Shadows

Post Reply