Some spell effects are displaying the editor ID rather than name in-game

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
Jemolk
Posts: 173
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Some spell effects are displaying the editor ID rather than name in-game

Post by Jemolk » 02 Jan 2019, 20:54

On the latest build from the Daily PPA, on Linux Mint. I'm using the OpenMW Multiple Teleport Marking mod, and the Greater Mark and Greater Recall effects are displayed as sEffectSummonCreature04 and sEffectSummonCreature05. They still work as intended, and still display the correct icons, so it doesn't seem to be an issue with load order, because the only thing that's borked here is the displayed name of the spell effects. This also affects the Fabricant summon effect, as it's likewise using its internal editor ID rather than its typical display name. This seems to be recent.

On a similar note, shields seem to be using their ground meshes for display, rather than body parts. This is only apparent because I'm running a mod that tries to add invisible shields (Raym's Invisible Shields), and uses the Heartrime Amulet ground mesh (so that if you drop one, it's not a giant yellow diamond). However, instead of an invisible shield, I have a Heartrime Amulet sticking out of my character's wrist.

User avatar
Capostrophic
Posts: 606
Joined: 22 Feb 2016, 20:32

Re: Some spell effects are displaying the editor ID rather than name in-game

Post by Capostrophic » 02 Jan 2019, 22:18

Can't reproduce either issue. Multiple Teleport Marking mod might be conflicting with some mod that also replaces these GMSTs (for example, a "dirty" mod). Raym's invisible shields works just fine for me too.

User avatar
Jemolk
Posts: 173
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Re: Some spell effects are displaying the editor ID rather than name in-game

Post by Jemolk » 04 Jan 2019, 07:19

Capostrophic wrote:
02 Jan 2019, 22:18
Can't reproduce either issue. Multiple Teleport Marking mod might be conflicting with some mod that also replaces these GMSTs (for example, a "dirty" mod). Raym's invisible shields works just fine for me too.
Weird. I can try fiddling with things a bit, see if things are any different for me, see if I can track down what's going on.

Post Reply