Help me to Fix MSVCP140.dll is Missing error

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
paulwilliams143
Posts: 7
Joined: 03 Dec 2018, 05:35

Help me to Fix MSVCP140.dll is Missing error

Post by paulwilliams143 » 03 Dec 2018, 05:39

I've tried almost every single solution to fix this issue but no help. I'm using Windows 8.1 laptop but no able to use OpenMW in any way.

Here's the exact error message I'm getting:

"The program can't start because MSVCP140.dll is missing from your computer. Try reinstalling the program to fix this problem."

Is there anything I'm missing or some kind of required file? I need some permanent solution.

User avatar
akortunov
Posts: 471
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Help me to Fix MSVCP140.dll is Missing error

Post by akortunov » 03 Dec 2018, 07:18

viewtopic.php?t=5461
Basically, you need the Microsoft Visual C ++ Redistributable package.
Last edited by akortunov on 03 Dec 2018, 07:19, edited 1 time in total.

paulwilliams143
Posts: 7
Joined: 03 Dec 2018, 05:35

Re: Help me to Fix MSVCP140.dll is Missing error

Post by paulwilliams143 » 03 Dec 2018, 07:19

I already tried it but no help.

User avatar
akortunov
Posts: 471
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Help me to Fix MSVCP140.dll is Missing error

Post by akortunov » 03 Dec 2018, 07:20

paulwilliams143 wrote:
03 Dec 2018, 07:19
I already tried it but no help.
Do you have the MSVCP140.dll installed on your system (I assume you installed mentioned package, right)?
I suppose it should be in the C:\Windows\System32\ on the 32-bit OS or in the C:\Windows\SysWOW64\ on the 64-bit OS.

User avatar
AnyOldName3
Posts: 1192
Joined: 26 Nov 2015, 03:25

Re: Help me to Fix MSVCP140.dll is Missing error

Post by AnyOldName3 » 03 Dec 2018, 14:44

It should be in System32 on either version - SysWOW64 is short for System32WindowsOnWindows64, and it's where the 32-bit versions of things live, because of course that makes sense. I think the justification is that when some applications were recompiled for 64-bit for the first time, it was realised they were hardcoded to load DLLs from System32 instead of wherever the linker said they'd be.
AnyOldName3, Master of Shadows

paulwilliams143
Posts: 7
Joined: 03 Dec 2018, 05:35

Re: Help me to Fix MSVCP140.dll is Missing error

Post by paulwilliams143 » 04 Dec 2018, 07:36

Hey, I couldn't find it in either locations.

I also looked it up on Google and they said that I have to add some type of DLL file into my PC manually.

Is that so?

User avatar
psi29a
Posts: 4366
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Help me to Fix MSVCP140.dll is Missing error

Post by psi29a » 04 Dec 2018, 09:10

Normally you have to install 32-bit (and 64-bit if your OS is 64-bit) of the redist... that should take care of things.

Here is the last thread that asked about MSVCP140.dll:
viewtopic.php?f=8&t=5461&p=59022

I answered and it was marked solved. ;)

User avatar
akortunov
Posts: 471
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Help me to Fix MSVCP140.dll is Missing error

Post by akortunov » 05 Dec 2018, 10:39

Is it possible to provide Microsoft libraties in OpenMW packages for Windows, or somehow notify users about they need a Microsoft Visual C++ Redistributable?

User avatar
AnyOldName3
Posts: 1192
Joined: 26 Nov 2015, 03:25

Re: Help me to Fix MSVCP140.dll is Missing error

Post by AnyOldName3 » 05 Dec 2018, 12:50

The release builds are supposed to contain the redists, and the only way I can see them not getting installed is if the user has already manually screwed something up by manually installing other DLLs from the same redist.
AnyOldName3, Master of Shadows

paulwilliams143
Posts: 7
Joined: 03 Dec 2018, 05:35

Re: Help me to Fix MSVCP140.dll is Missing error

Post by paulwilliams143 » 06 Dec 2018, 06:05

psi29a wrote:
04 Dec 2018, 09:10
Normally you have to install 32-bit (and 64-bit if your OS is 64-bit) of the redist... that should take care of things.

Here is the last thread that asked about MSVCP140.dll:
viewtopic.php?f=8&t=5461&p=59022

I answered and it was marked solved. ;)
Sure, I'll go through the thread that you mentioned.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest