Godawful performance when building debug builds of OpenMW from source on Windows

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
heilkitty
Posts: 128
Joined: 11 Aug 2011, 07:57
Location: Vivec City, MW
Contact:

Godawful performance when building debug builds of OpenMW from source on Windows

Post by heilkitty » 04 Aug 2018, 10:07

By default, it's built with the Debug configuration. Does it have something to do with that?
In Soviet MoЯЯowind, Almalexia kills YOU!!

User avatar
akortunov
Posts: 389
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Godawful performance when built OpenMW from source on Windows

Post by akortunov » 04 Aug 2018, 10:27

heilkitty wrote:
04 Aug 2018, 10:07
By default, it's built with the Debug configuration. Does it have something to do with that?
Only make Visual Studio to build Release configuration. Debugs builds are really slow.

User avatar
heilkitty
Posts: 128
Joined: 11 Aug 2011, 07:57
Location: Vivec City, MW
Contact:

Re: Godawful performance when built OpenMW from source on Windows

Post by heilkitty » 04 Aug 2018, 11:20

Yeah, the difference is huge. Maybe, it would be better to make the Release option default?
In Soviet MoЯЯowind, Almalexia kills YOU!!

User avatar
AnyOldName3
Posts: 1080
Joined: 26 Nov 2015, 03:25

Re: Godawful performance when built OpenMW from source on Windows

Post by AnyOldName3 » 04 Aug 2018, 13:03

Release is next to useless for development work as you can't use the debugger without being fluent in assembly. Remember, we're setting up a development environment, not a tool for users to test out the same new features offered by nightlies or an AppVeyor artefact.
AnyOldName3, Master of Shadows

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests