Textures and collision not loading

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Textures and collision not loading

Post by Cartifer » 12 Jul 2018, 12:11

Hi,

I am trying to run OpenMW on a shared computer running Red Hat 64-bit. Because many common dependencies are missing and I do not have sudo rights, using Wine is usually the easiest. I am therefore using 64-bit Wine to run OpenMW for Windows.

OpenMW installs just fine, and the launcher works too. However, after pressing "New Game" and watching the introductory dream sequence, all textures are yellow and the player falls through the ship. I screenshot this, see
OpenMW.zip
Zipped folder home/My Games/OpenMW/
(150 KiB) Downloaded 1 time
. I have confirmed this behavior in 0.42, 0.43, and 0.44.

When running openmw.exe instead of openmw-launcher.exe, the same problem occurs and the error output continuously repeats errors of the type
"
Failed to load 'meshes/c/c_m_shirt_ua_common01.nif': NIFFile Error: Record number 2 out of 5 is blank.
File: meshes/c/c_m_shirt_ua_common01.nif, using marker_error.nif instead
"

Any idea what causes this?

User avatar
psi29a
Posts: 3989
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Textures and collision not loading

Post by psi29a » 12 Jul 2018, 12:25

Why not use the generic build? It has all the dependencies required to run, no need to install anything on the host system.
https://github.com/OpenMW/openmw/releases
openmw-0.43.0-Linux-64Bit.tar.gz
openmw-0.43.0-Linux.tar.gz

Seriously... we're not going to put much effort into making OpenMW work with wine when there is a native Linux version.

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 12 Jul 2018, 17:09

Thanks for the swift reply psi! I will check on this thread more frequently now. I tried the generic build at first, but it fails to run, both 64Bit and regular. I will now post the errors from the generic build. All of the following is 0.43 and 64-Bit.


When I run "openmw-wizard" I get the following error:
Spoiler: Show
Why does the error begin with "./openmw-wizard.x86_64:"? Weird.


When I run "openmw-wizard.x86_64" I get the following error:
Spoiler: Show
This seems peculiar, because the file "lib/libunshield.so.0" does exist.


When I run "openmw-launcher" I get the following error:
Spoiler: Show
This is what meant by missing dependencies, perhaps i misused the term.


When I run "openmw-launcher.x86_64" I get the following error:
Spoiler: Show

I have also tried to compile the source code, and get similar errors "X: Y not found (required by Z)". I understand that Wine is not supported. The reason for me originally asking about Wine was because it got me the furthest. In retrospect, the errors from the generic build presented in this reply would have made a better thread.


In brief: "openmw-wizard.x86_64" says it cannot find "libunshield.so.0", but the file does exist in the folder "lib". How do I fix this?

User avatar
akortunov
Posts: 302
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Textures and collision not loading

Post by akortunov » 12 Jul 2018, 18:20

Cartifer wrote:
12 Jul 2018, 17:09
In brief: "openmw-wizard.x86_64" says it cannot find "libunshield.so.0", but the file does exist in the folder "lib". How do I fix this?
Install missing packages for your distro?
Also if you have a lot of problem with dependencies, you can try to use the Flatpak OpenMW package from download page.

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 12 Jul 2018, 19:21

akortunov wrote:
12 Jul 2018, 18:20
Install missing packages for your distro?
Unfortunately that not possible as far as I know. The computer is shared, and I do not have the rights to install packages.

akortunov wrote:
12 Jul 2018, 18:20
Also if you have a lot of problem with dependencies, you can try to use the Flatpak OpenMW package from download page.
Thanks for the suggestion! I will try it tomorrow and return with results.

User avatar
psi29a
Posts: 3989
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Textures and collision not loading

Post by psi29a » 12 Jul 2018, 21:11

Does these RC builds work for you?
https://redfortune.de/openmw/rc/openmw- ... RC1.tar.gz
https://redfortune.de/openmw/rc/openmw- ... RC1.tar.gz

If they also have missing deps, then k1ll (our generic package builder) should includes these.

As for the libs, you need to add them to your lib path such as using LD_PRELOAD
https://stackoverflow.com/questions/426 ... load-trick
https://rafalcieslak.wordpress.com/2013 ... -programs/

something like:

Code: Select all

LD_PRELOAD=lib/libunshield.so.whatever  ./openmw-launcher

K1ll
Posts: 136
Joined: 06 Aug 2011, 21:54

Re: Textures and collision not loading

Post by K1ll » 12 Jul 2018, 22:34

Please try using the current RC2 builds:
32 Bit
64 Bit

There are also nightly builds here:
Nightlies

They have the same dependencies included as the current RC builds.
Cartifer wrote:
12 Jul 2018, 17:09
Thanks for the swift reply psi! I will check on this thread more frequently now. I tried the generic build at first, but it fails to run, both 64Bit and regular. I will now post the errors from the generic build. All of the following is 0.43 and 64-Bit.


When I run "openmw-wizard" I get the following error:
Spoiler: Show
Why does the error begin with "./openmw-wizard.x86_64:"? Weird.
Yeah libcrypto and libssl were missing in the openmw 0.43.0 builds.
When I run "openmw-wizard.x86_64" I get the following error:
Spoiler: Show
This seems peculiar, because the file "lib/libunshield.so.0" does exist.
That's just because when you run the binary directly instead of the script the lib directory is not included in the library search path.
When I run "openmw-launcher" I get the following error:
Spoiler: Show
This is what meant by missing dependencies, perhaps i misused the term.
That's quite interesting. Which version of Red Hat Enterprise Linux are you trying to run the binaries on? Red Hat Enterprise Linux 6 or Red Hat Enterprise Linux 7? The binaries are compiled on CentOS 6 so the equivalent to Red Hat Enterprise Linux 6 but with a newer compiler toolchain. Though i hoped they would be binary compatible with standard CentOS/RHEL 6.

Edit: I just remembered that the openmw 0.43.0 builds were still compiled on my Debian wheezy machines. That's why the libraries have a dependency on GLIBCXX_3.4.15 which is newer than what is used on CentOS 6 (GLIBCXX_3.4.12). The openmw-0.44.0 libraries all depend on GLIBCXX_3.4.11 so this problem should be fixed as well.
When I run "openmw-launcher.x86_64" I get the following error:
Spoiler: Show

I have also tried to compile the source code, and get similar errors "X: Y not found (required by Z)". I understand that Wine is not supported. The reason for me originally asking about Wine was because it got me the furthest. In retrospect, the errors from the generic build presented in this reply would have made a better thread.


In brief: "openmw-wizard.x86_64" says it cannot find "libunshield.so.0", but the file does exist in the folder "lib". How do I fix this?

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 13 Jul 2018, 13:45

I tried using Flatpak, but it was not installed on the computer, and I don't have the rights to install it.

psi29a wrote:
12 Jul 2018, 21:11
Does these RC builds work for you?
https://redfortune.de/openmw/rc/openmw- ... RC1.tar.gz
https://redfortune.de/openmw/rc/openmw- ... RC1.tar.gz

If they also have missing deps, then k1ll (our generic package builder) should includes these.
No, those builds didn't work. Here are the error messages:
Spoiler: Show
Spoiler: Show
Spoiler: Show
Spoiler: Show
They are curiously similar. Does the name "_ZN9QListData11detach_growEPii" mena anything to you?

psi29a wrote:
12 Jul 2018, 21:11
As for the libs, you need to add them to your lib path such as using LD_PRELOAD
https://stackoverflow.com/questions/426 ... load-trick
https://rafalcieslak.wordpress.com/2013 ... -programs/

something like:

Code: Select all

LD_PRELOAD=lib/libunshield.so.whatever  ./openmw-launcher
I tried this, and it worked. "openmw-wizard.x86_64" does now find "libunshield.so.0", but complains about not finding "libboost_system.so.1.49.0". So I added that one too, and progressively 20 or so more until I got an error about "libssl.so.1.0.0". Adding this to LD_PRELOAD does not help, because the file "libssl.so.1.0.0" does not exist anywhere in the OpenMW folder, I used "find -name libssl.so.1.0.0" to make sure. It's probably not a coincidence that running "openmw-wizard" immediately gives the error about not finding "libssl.so.1.0.0".


I will now try K1ll's suggestions.
Edit:
K1ll wrote:
12 Jul 2018, 22:34
Please try using the current RC2 builds:
32 Bit
64 Bit

There are also nightly builds here:
Nightlies

They have the same dependencies included as the current RC builds.
I tried both RC2 builds and the latest nightly 64-Bit build "openmw-20180713-0bd6078826de025fd4a4b91f16ef62cb725d6625-Linux-64Bit.tar.gz". They all give the same error, identical to the letter: "undefined symbol: _ZN9QListData11detach_growEPii".

K1ll wrote:
12 Jul 2018, 22:34
That's quite interesting. Which version of Red Hat Enterprise Linux are you trying to run the binaries on? Red Hat Enterprise Linux 6 or Red Hat Enterprise Linux 7? The binaries are compiled on CentOS 6 so the equivalent to Red Hat Enterprise Linux 6 but with a newer compiler toolchain. Though i hoped they would be binary compatible with standard CentOS/RHEL 6.
This is what the system monitor says:
Red Hat Enterprise Linux Workstation
Release 6.9 (Santiago)
Kernel Linux 2.6.32-696.18.7.el6.x86_64
GNOME 2.28.2

User avatar
akortunov
Posts: 302
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Textures and collision not loading

Post by akortunov » 15 Jul 2018, 05:33

Cartifer wrote:
13 Jul 2018, 13:45
"undefined symbol: _ZN9QListData11detach_growEPii".
Looks like Qt packages, installed on your system, have different version, than OpenMW requires.
For example, your system has Qt 4.6, but binary requires Qt 4.8.

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 15 Jul 2018, 12:57

akortunov wrote:
15 Jul 2018, 05:33
Cartifer wrote:
13 Jul 2018, 13:45
"undefined symbol: _ZN9QListData11detach_growEPii".
Looks like Qt packages, installed on your system, have different version, than OpenMW requires.
For example, your system has Qt 4.6, but binary requires Qt 4.8.
That's unfortunate, because I don't have the rights to update Qt. I notice that when i run "openmw" instead of "openmw-launcher", I get another error message instead about "libopus.so.0" not existing. (I did notice that version 0.36 contains "libopus.so.0") Is Qt only used for the launcher? If that's the case, there is still hope.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests