Scene Toolbar Icon Request

Involved development of the OpenMW construction set.
User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 24 Nov 2014, 21:37

Actually it is a bit more complex. The first two are mode selector buttons (kinda like radio buttons). Then we have one or two composite toggle buttons (depending on the subview type), then a push button and finally another mode button, which will add one or more additional buttons of varying types below it (depending on which mode is selected).
I want to keep it that way, because the varying buttons would be confusing if they were to appear in the middle of the toolbar.

Using the insensitive state seems to work well enough.

I am not sure where the 14px came from. I don't think we use any of these. The toolbar button icons are 48x48 and the record type/resources type icons are 32x32 (using 48x48 placeholder icons there isn't a problem).

User avatar
Shnatsel
Posts: 55
Joined: 31 Oct 2014, 01:06
Location: Moscow
Contact:

Re: Scene Toolbar Icon Request

Post by Shnatsel » 24 Nov 2014, 22:40

Zini wrote: The first two are mode selector buttons (kinda like radio buttons). Then we have one or two composite toggle buttons (depending on the subview type), then a push button and finally another mode button, which will add one or more additional buttons of varying types below it (depending on which mode is selected).
Oooh! You might want to add a separator before that last static button, in that case. Or even an "Editing:" label.
Zini wrote:Using the insensitive state seems to work well enough.
Cool! So here are three icon variants for your consideration. I don't like the icon from my demo above anymore :P
It'd be best if you could try them in-place with my previous icon visible. I've tested it on mockups of the default state of that icon only.
14_play4_masked.png
14_play4_masked.png (3.41 KiB) Viewed 4356 times
14_play7_masked.png
14_play7_masked.png (3.38 KiB) Viewed 4356 times
14_play_b4_masked.png
14_play_b4_masked.png (3.36 KiB) Viewed 4356 times
Please let me know which one you prefer and why, as I am temporarily unable to judge them after staring them for so long. Also, please let me know if there are any issues with the preferred version and I'll do my best to fix them.
Zini wrote:I am not sure where the 14px came from.
The icon right above the "play" in your screenshot... I've just figured out that that's the button you're replacing with my composite icon, so you won't need a placeholder there indeed ;)

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 25 Nov 2014, 10:22

Oooh! You might want to add a separator before that last static button, in that case. Or even an "Editing:" label.
Not only there, but also between the other button groups:
- Lighting-mode, camera-mode
- Visibility-buttons
- Run
- Editing mode and sub-tools
Not necessarily a separator and certainly not a label, but at least some kind of visual separation (additional space maybe). We'll polish the toolbar when it is finished.
Cool! So here are three icon variants for your consideration. I don't like the icon from my demo above anymore :P
It'd be best if you could try them in-place with my previous icon visible. I've tested it on mockups of the default state of that icon only.
Okay, will get to it in a bit.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 25 Nov 2014, 11:56

There:
Attachments
3.png
2.png
1.png

User avatar
Shnatsel
Posts: 55
Joined: 31 Oct 2014, 01:06
Location: Moscow
Contact:

Re: Scene Toolbar Icon Request

Post by Shnatsel » 25 Nov 2014, 15:19

Thanks!

So here's the latest iteration:
14_play9_masked.png
14_play9_masked.png (3.52 KiB) Viewed 4275 times
I tried to make it not look too desaturated next to the view toggle icon while also not attracting too much attention, and make it readable but not too high-contrast in the insensitive state.

Please let me know if there are any other issues with this icon. If not, I'm proposing it for merging.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 25 Nov 2014, 19:38

Looks good to me.

User avatar
Shnatsel
Posts: 55
Joined: 31 Oct 2014, 01:06
Location: Moscow
Contact:

Re: Scene Toolbar Icon Request

Post by Shnatsel » 25 Nov 2014, 22:36

Proposed for merging: https://github.com/OpenMW/openmw/pull/377
Zini wrote:We need another set of icons of the same type (but a separate button) for cell marker, cell arrows and cell borders. But since only one of these is currently implemented and we don't know exactly yet how the other two will look, maybe we should wait with that.
...
And then we have the edit mode buttons: Reference/object editing mode, pathgrid editing mode, terrain shape editing mode, terrain texture editing mode, terrain vertex paint editing mode and terrain movement mode.
It seems it's too early to tackle either of those, so drop me a line at shnatsel@gmail.com when you need them. I hope I'll still be available at the time.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 26 Nov 2014, 10:40

Okay. Looks like the toolbar icons are done for now. Maybe we should focus on the missing record type and resource type icons. Been a while since I looked at that and I can't say what is missing off the top of my head. I will look it up and make you a list.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 27 Nov 2014, 08:16

Turns out that we have most of the icons already. They were just not in use. What we are still missing are the resources icons and some misc stuff.

Here is my list:

- Mesh
- Icon
- Music
- Sound File
- Texture
- Video
- Debug Profile


The existing icons all seem to be 32x32. You can see some of them in the referenceables tables (may require switching on the use of icons in the user settings first).

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: Scene Toolbar Icon Request

Post by Zini » 27 Nov 2014, 09:05

Finally figured out why the visibility button was causing me trouble. There was a bug on my end, but the numbering of the status icons seems also wrong. Some mixup with terrain, pathgrid and possibly fog. If necessary I can go over it manually re-order the files, but since you mentioned you were doing it via a script maybe you could have another look at that first.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests