Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
claudekennilol
Posts: 79
Joined: 01 Aug 2012, 20:48

Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by claudekennilol » 09 Jul 2019, 14:46

Last night I installed the latest nigthly build (july 8 2019 windows x64) and it no longer included my "my games/openmw/data" folder to automatically pull mods from. I had to go into the config and manually add the path for that dir--I don't remember having to do this the first time I set it up (and reinstalling it didn't mess with the config so to me that implies something changed). Was this change intentional or did I just miss something when updating?

User avatar
lysol
Posts: 1316
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by lysol » 17 Jul 2019, 13:41

What do you mean with folder to pull mods from? OpenMW does not automatically create a directory where you put your mods. You put them where you want and point to that directory in your openmw.cfg file.

So the strange thing is rather if your openmw.cfg suddenly lost the location for the mods when you updated. That file is not supposed to be touched when you update, unless you ran the .ini wizard again, in which case I think your old file gets replaced.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
Capostrophic
Posts: 649
Joined: 22 Feb 2016, 20:32

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by Capostrophic » 17 Jul 2019, 13:44

Check if you global/local openmw.cfgs are intact, they should be present in your openmw installation folder and must contain that exact folder in the form of "?userdata?data" data-local path. You shouldn't ever need to add it into openmw.cfg.

claudekennilol
Posts: 79
Joined: 01 Aug 2012, 20:48

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by claudekennilol » 17 Jul 2019, 14:52

It looks like it's the Mod Organizer 2 export tool that's doing it. But it's odd because I never had to add that location in the first place.

User avatar
lysol
Posts: 1316
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by lysol » 17 Jul 2019, 16:56

Sounds like we need to summon AnyOldName3.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

claudekennilol
Posts: 79
Joined: 01 Aug 2012, 20:48

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by claudekennilol » 17 Jul 2019, 20:43

Yeah I don't know where the issue is. When I first posted this, I fixed it by adding "C:/Users/me/my games/openmw/data" to my mod paths in my config file. But I didn't have to do that initially--I only had to do that after I updated to the nightly build mentioned in my first post. So I don't know if the engine/launcher looked at that path without an entry in the config, if openmw-cs added it to the config when I made some simple global variable edits, or something else. But re-rereunning the MO2 export tool removed that line I added (which honestly I'd expect it to) so I don't think the blame lies with AnyOldName3's MO2 export plugin.

User avatar
AnyOldName3
Posts: 1531
Joined: 26 Nov 2015, 03:25

Re: Latest nightly as of July 8th 2019 - didn't include my games/openmw/data

Post by AnyOldName3 » 19 Jul 2019, 00:31

Code: Select all

C:/Users/me/my games/openmw/data
should be added automatically as a data directory by the install directory's openmw.cfg where it says

Code: Select all

data-local="?userdata?data"
When the engine is started, it combines all the data= lines in the install directory's openmw.cfg and the user directory's openmw.cfg, and then once all of those have been read, it adds the one directory set as data-local. My Mod Organizer plugin doesn't touch the data-local setting, so if you've broken it in your install dirtectory's openmw.cfg or overridden a correct value in your install directory's openmw.cfg with an incorrect value in your user openmw.cfg, that's why it's not working. I'd check both of those files for data-local lines.
AnyOldName3, Master of Shadows

Post Reply