Do we support libbullet 2.83?

Everything about development and the OpenMW source code.
Post Reply
User avatar
psi29a
Posts: 3476
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Do we support libbullet 2.83?

Post by psi29a » 01 Jan 2018, 10:08

From a Debian bugreport:
I tried to build openmw from debian's git with libbullet-dev 2.83.7+dfsg-5 from stretch and get a compilation error.
Since Stretch is the latest stable, should we be supporting bullet this far back? If not, do we have a lower bound?

User avatar
Zini
Posts: 5140
Joined: 06 Aug 2011, 15:16

Re: Do we support libbullet 2.83?

Post by Zini » 01 Jan 2018, 15:13

I think there was an issue with 2.83. I don't remember what it was, but it was severe enough to force me to update (which is something I generally don't do unless it is absolutely necessary). 2.86 should do as lower bound.

User avatar
psi29a
Posts: 3476
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Do we support libbullet 2.83?

Post by psi29a » 01 Jan 2018, 16:41

OK, then there will be no OpenMW build for Stretch (latest Debian Stable). I'll fix the release. :)

magamo
Posts: 83
Joined: 28 May 2016, 17:28

Re: Do we support libbullet 2.83?

Post by magamo » 01 Jan 2018, 16:59

Looks like the last release that was buildable with bullet 2.83 was openmw 0.41.0

Post Reply

Who is online

Users browsing this forum: magamo and 3 guests