Page 1 of 1

[Manjaro Linux] Unable to launch due to provided lib files not being detected

Posted: 05 Jan 2020, 04:14
by name
Whenever I try to launch any of the executable files in openmw-20200103-a5289035e28257585d94fe4ca20e75c2da280f12, nothing happens. I launched them in the terminal to see exactly what the problem was, and it was because one of the libraries was "missing". I say missing in that way, because all of the libs required by openmw came with the build to begin with in a folder. Why isn't the programs detecting the lib files in the folder?

Re: [Manjaro Linux] Unable to launch due to provided lib files not being detected

Posted: 05 Jan 2020, 10:22
by Settyness
It's been a while since I used a nightly build, but if you are attempting to run the application without your package manager, you are responsible for providing the dependencies such as `qt4` and (I think) `bullet`. Each of the error messages will clue you in on what package you are missing. Keep installing packages until it finally runs. `qt4` must be built from the AUR.

Re: [Manjaro Linux] Unable to launch due to provided lib files not being detected

Posted: 12 Jan 2020, 19:11
by name
Nightly builds contain all libs required to run openmw. Responsibility on providing dependencies is irrelevant. The problem is that the program will not look in the libs folder for it's required dependencies. libosg.so.131 is a package that the program requires to run, yet it's already included in a lib folder in the openmw build. That, and i can't even find the lib package within my package manager.

Re: [Manjaro Linux] Unable to launch due to provided lib files not being detected

Posted: 12 Jan 2020, 19:21
by name
Actually, I'm now able to run openmw. Instead of running the executables, I ran the shell scripts instead. I don't exactly know how running from the scripts is different from running the exes, but it works, and I'm satisfied with that.