Spiky, moving shadows on vertical surfaces.

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
1Mac
Posts: 47
Joined: 20 Feb 2019, 19:50

Spiky, moving shadows on vertical surfaces.

Post by 1Mac » 02 Apr 2019, 20:32

This is on Mac OS, build OpenMW-29032019-d5051bd4. They look like this:

Screenshot

Screenshot

Screenshot

They seem to look the worst when entering a cell. They move around a bit horizontally and eventually disappear, but can reappear if I take another look at them.

Current settings:
Spoiler: Show
These have been futzed with a bit, but I was still seeing the issue no matter what I tried. (Yes, this is the proper settings.cfg file in the proper path. I pasted default values to make editing them easier.)

I don't ever submit bug reports for projects like this, so I'm sure I'm missing some helpful detail. Let me know if there's anything useful I can add.

User avatar
AnyOldName3
Posts: 1477
Joined: 26 Nov 2015, 03:25

Re: Spiky, moving shadows on vertical surfaces.

Post by AnyOldName3 » 02 Apr 2019, 21:31

The best settings to meddle with are probably the normal offset distance and front face culling. You might also find that turning on the debug hud helps, but that's probably most useful for screenshots you're posting here.
AnyOldName3, Master of Shadows

1Mac
Posts: 47
Joined: 20 Feb 2019, 19:50

Re: Spiky, moving shadows on vertical surfaces.

Post by 1Mac » 04 Apr 2019, 19:42

The effect persists whether front face culling is enabled or not. Lowering Normal Offset Distance seems to help the problem by reducing the peaks of the spikes (the screenshots were with the "sensible" maximum of two), but it's still an issue. Setting it to 0 makes it go away almost entirely but of course introduces pretty bad flickering in places.

I don't think the debugging hud is helping me make sense of what's going on, sorry to say.

1Mac
Posts: 47
Joined: 20 Feb 2019, 19:50

Re: Spiky, moving shadows on vertical surfaces.

Post by 1Mac » 09 Apr 2019, 04:14

Sadly, unless there's a fix I'm missing, I'm going to have to disable world object shadows. My screenshots might not do justice to how bad a problem it is. The shadow spikes are moving fast, and erratically. It's almost like having static on parts of the screen, the opposite of an enhancement. I've tried all kinds of settings and combinations of settings, and the results are the same.

I realize shadows are a beta feature, and I'd like to see them be the best they can be. Please let me know if there's anything I can do to help solve the problem!

User avatar
AnyOldName3
Posts: 1477
Joined: 26 Nov 2015, 03:25

Re: Spiky, moving shadows on vertical surfaces.

Post by AnyOldName3 » 09 Apr 2019, 16:50

I thought I'd made another post in this thread, but it's missing, so I guess I accidentally closed the tab without submitting it.

Screenshots with the debug HUD on should give me some more information that I can use to try and figure out what's going on. That's what I meant by saying it would help.
AnyOldName3, Master of Shadows

1Mac
Posts: 47
Joined: 20 Feb 2019, 19:50

Re: Spiky, moving shadows on vertical surfaces.

Post by 1Mac » 10 Apr 2019, 04:44

Okay, how's this?
Image

Image

Image

Image

Image

Image

User avatar
AnyOldName3
Posts: 1477
Joined: 26 Nov 2015, 03:25

Re: Spiky, moving shadows on vertical surfaces.

Post by AnyOldName3 » 10 Apr 2019, 14:29

Those screenshots aren't at native resolution, which makes looking at certain parts of the image a little harder than ideal. Somehow they've been rescaled.

One thought I've had is that you're using an extended viewing distance and distant terrain without having compute tight scene bounds enabled. It's possible that that might make some difference.

It might also be a good idea to upload an APITrace of a few frames when the issue is visible (get into a position where there's the issue, save the game, and reload the save when running OpenMW through APITrace). That should help me figure out whether Apple's drivers are doing something weird or whether the same issue would occur on someone else's computer in the same situation.
AnyOldName3, Master of Shadows

BaronPampa
Posts: 16
Joined: 04 Aug 2017, 12:50

Re: Spiky, moving shadows on vertical surfaces.

Post by BaronPampa » 10 Apr 2019, 18:42

I've had the same issue on Linux when checking out your work(which is awesome, by the way). I assumed that you are aware of the issue and working on improving it. I can provide you with whatever info you need, I'll just need to redownload Morrowind from gog.

User avatar
raevol
Posts: 3000
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: Spiky, moving shadows on vertical surfaces.

Post by raevol » 10 Apr 2019, 18:46

I just messed with my settings because I was having this issue too. This seems to fix things, though I'll need to play more to see the full impact:

Code: Select all

[Shadows]
enable shadows = true
number of shadow maps = 4
allow shadow map overlap = true
split point uniform logarithmic ratio = 0.5
split point bias = 0.0
enable debug hud = false
enable debug overlay = false
compute tight scene bounds = true
shadow map resolution = 4096
minimum lispsm near far ratio = 0.25
polygon offset factor = 1.1
polygon offset units = 4.0
normal offset distance = 8.0
use front face culling = true
actor shadows = true
player shadows = false
terrain shadows = true
object shadows = true
enable indoor shadows = false
Also, @AnyOldName3 if any of this looks dumb let me know and I will test your suggestions...

User avatar
AnyOldName3
Posts: 1477
Joined: 26 Nov 2015, 03:25

Re: Spiky, moving shadows on vertical surfaces.

Post by AnyOldName3 » 10 Apr 2019, 20:23

Turning off player shadows is really weird. It's so weird, in fact, that Scrawl didn't see any point in there being an option for it. There's no conceivable way it could be causing the issues in this thread.

For split point uniform logarithmic ratio the jury's out on which value is genuinely the best middle ground for all situations, but lots of people prefer to have it at 1.0 or just below 1.0, especially with an increased view distance.

8.0 strikes me as a very large value for normal offset distance. If it's the one thing making the artefacts go away, that's fine, and maybe the documentation for the recommended range should be changed, but if everything works how I expect, it would make everything seem to float 11cm off the ground, which would be noticeable.
AnyOldName3, Master of Shadows

Post Reply