Page 1 of 1

Config settings suddenly missing

Posted: 25 Feb 2019, 06:14
by psychotrip
I've been playing openmw for a while now without issue, but a few minutes ago something bizarre happened and I don't know why or how to fix it.

It seems that somehow, about 20 minutes ago, my settings.cfg file was altered. All I did was close the game and reboot, and suddenly all my settings were reset. My draw distance was back to vanilla settings, my resolution was off, and my menu windows were set to default sizes.

When I checked the settings config not only was everything reset but the majority of it was missing altogether. There's nothing for view distance, cells, or anything. This is literally the extent of my current config file (note that I changed my resolution back to normal and tweaked a few things in the past few minutes):


[Video]
fullscreen = true
resolution x = 1920
resolution y = 1080

[Game]
prevent merchant equipping = true
show effect duration = true
show enchant chance = true
show melee info = true
show projectile damage = true

[Saves]
character = Qorwynn - 1

[Windows]
inventory h = 0.528704
inventory w = 0.45
inventory x = 0
inventory y = 0.475
map h = 0.491667
map w = 0.551042
map x = 0.448438
map y = 0
spells h = 0.297222
spells w = 0.359896
spells x = 0.600521
spells y = 0.678704
stats h = 0.476852
stats w = 0.45
stats x = -0.0015625
stats y = -0.0037037

Am I just going insane? I could've sworn there were way more settings than this. Do I just add them back manually? What even happened here? Note that I didn't touch the config file at all before it reset. I was just playing the game normally, shut it down, then turned it back on. Any ideas?

Re: Config settings suddenly missing

Posted: 25 Feb 2019, 19:24
by AnyOldName3
A guess would be that something happened to put something wrong into the file, and then when the engine was started, it stripped out any lines it thought had errors. You can just copy and paste lines out of settings-default.cfg to get the other settings back.

Re: Config settings suddenly missing

Posted: 26 Feb 2019, 02:07
by psychotrip
AnyOldName3 wrote:
25 Feb 2019, 19:24
A guess would be that something happened to put something wrong into the file, and then when the engine was started, it stripped out any lines it thought had errors. You can just copy and paste lines out of settings-default.cfg to get the other settings back.
That's the weird thing: I can't find setting-default.cfg. It's nowhere to be found. Anyone know if I can download it on its own somehow?

Re: Config settings suddenly missing

Posted: 26 Feb 2019, 03:51
by AnyOldName3
It should be in the same directory as the OpenMW executable, e.g. C:\Program Files\OpenMW 0.44\settings-default.cfg on Windows. You've definitely found the OpenMW executable on its own without settings-default.cfg? If so, that's probably indicative of a bigger problem.

Re: Config settings suddenly missing

Posted: 20 May 2019, 03:09
by psychotrip
Super delayed response, but I found settings-default.cfg. It was exactly where you said it should be. Not sure why it wasn't showing up when I searched for it.

Anyway, I just copy and paste it into settings.cfg? Do I replace the stuff already in settings.cfg? Or add this stuff to it? Thanks in advance!

Re: Config settings suddenly missing

Posted: 20 May 2019, 12:35
by AnyOldName3
OpenMW loads settings from settings.cfg, and anything that isn't in settings.cfg gets loaded from settings-default.cfg. If you're fine with a setting having the default value, it's fine to leave it out of settings.cfg and fine to have it there with the default value, but if you want a non-default value, you need to have a value in settings.cfg, which can be done by typing it manually or by copying the default out of settings-default.cfg, pasting it into settings.cfg, and changing the value after pasting it.