Water Shader turns into a pixelated mess

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
User avatar
drakovyrn
Posts: 63
Joined: 17 Feb 2017, 03:51
Contact:

Re: Water Shader turns into a pixelated mess

Post by drakovyrn » 27 Nov 2018, 07:29

Hmm, I'd always thought this was regular behavior and that the shader simply required refining.

However, this has always happened with me as well. My tower is an i7-3770 CPU with integrated Intel graphics.

User avatar
lysol
Posts: 1330
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Water Shader turns into a pixelated mess

Post by lysol » 27 Nov 2018, 10:29

Strange. Never happened to me with intel integrated on ubuntu. Haven't tried yet with my AMD card, open source drivers, on ubuntu due to that computer now being hidden behind tons of stuff from a room I changed the floor in.

EDIT: Updated post with OS. Never had a problem with nvidia on windows either.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

User avatar
psi29a
Posts: 4644
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Water Shader turns into a pixelated mess

Post by psi29a » 27 Nov 2018, 11:05

drakovyrn wrote:
27 Nov 2018, 07:29
Hmm, I'd always thought this was regular behavior and that the shader simply required refining.

However, this has always happened with me as well. My tower is an i7-3770 CPU with integrated Intel graphics.
What driver? FOSS or proprietary, what OS?

User avatar
wareya
Posts: 338
Joined: 09 May 2015, 13:07

Re: Water Shader turns into a pixelated mess

Post by wareya » 27 Nov 2018, 12:56

Might it be depth buffer resolution related?

EDIT: Nope. https://imgur.com/a/VoCQmUL

FWIW I thought this was a known problem.
paying attention to #1751 #2473 #3609 #3862/#3929 #3807 #4297 #4623

User avatar
AnyOldName3
Posts: 1565
Joined: 26 Nov 2015, 03:25

Re: Water Shader turns into a pixelated mess

Post by AnyOldName3 » 27 Nov 2018, 16:20

I ran the shader through a verifier, and it didn't print any errors or warnings until I also told it to create SPIRV binaries, at which point it failed because you can't make SPIRV binaries from GLSL 1.2.
AnyOldName3, Master of Shadows

User avatar
Jemolk
Posts: 191
Joined: 20 Mar 2017, 02:12
Location: Sadrith Mora

Re: Water Shader turns into a pixelated mess

Post by Jemolk » 29 Nov 2018, 01:41

...Huh. I've never seen this before. On Mint, myself, and at least most of the people reporting this are on Windows...Might this be OS-related?

User avatar
raevol
Posts: 3017
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: Water Shader turns into a pixelated mess

Post by raevol » 29 Nov 2018, 04:18

I can confirm this on AMD, Ubuntu, FOSS drivers.
[email protected]:~$ glxinfo | grep Open
OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10 / DRM 3.23.0 / 4.15.0-39-generic, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
I never noticed it before, but I promise it's because I wasn't looking close enough, I would have never seen this if someone hadn't pointed it out.

User avatar
drakovyrn
Posts: 63
Joined: 17 Feb 2017, 03:51
Contact:

Re: Water Shader turns into a pixelated mess

Post by drakovyrn » 29 Nov 2018, 08:12

Well... this is weird. Just tested on Windows 7 and Solus + FOSS drivers, and I was completely unable to recreate the pixelization bug. I have no idea what happened, but it seems the issue on my end was resolved at some point. :|

smokeyninja
Posts: 19
Joined: 26 Oct 2018, 07:51

Re: Water Shader turns into a pixelated mess

Post by smokeyninja » 29 Nov 2018, 08:22

windows 10, openmw 0.44, rx560, latest drivers from AMD, issue is present. Funny I never noticed it until now and now it's gonna drive me crazy :lol:
Openmw 0.44.0 Windows 10 i7 7700k rx560

Post Reply