Constant 60 FPS but annoying micro-stuttering

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Jerome89
Posts: 8
Joined: 04 Oct 2018, 12:35

Constant 60 FPS but annoying micro-stuttering

Post by Jerome89 » 20 Nov 2018, 12:18

Hello,

I need help to understand my problem :-) Most of the time, I get 60 FPS while playing with OpenMW. Nevertheless, every 5 or 6 seconds, I get some micro stuttering. Some more informations :
1. I'm playing using OpenMW nightly builds
2. This problem occurs since latests 0.44 nightly builds revisions (currently on 0.46, problem still occurs)
3. If I load a savegame from Seyda Neen (at the very beginning) and run off the city for 2 minutes :
- With official 0.44 release: no stuttering, 60 FPS, smooth cells transition
- With latest nightly build (or 13th of november 0.44 revision) : stuttering every 5 seconds, 60 FPS, smooth cells transition

In both cases, configuration file is the same (Normal maps are disabled, force_shaders is activated) and same mods are installed.

About textures mods, in both cases I'm using :
- HD Vanilla textures
- VanillaPlus textures mod (Purist version)

Also, I've tried playing with different v-sync settings :
- ingame v-sync
- Nvidia (1070 8GO) v-sync ON and ingame v-sync OFF
=> Problem is still there, maybe a little less noticeable with Nvidia v-sync

Can someone tells me what the problem might be ? i'm a bit lost, and the frequent micro-stuttering are really annoying

Jerome

User avatar
AnyOldName3
Posts: 1559
Joined: 26 Nov 2015, 03:25

Re: Constant 60 FPS but annoying micro-stuttering

Post by AnyOldName3 » 20 Nov 2018, 13:04

Press F3 until a bunch of bars appear at the top and post a screenshot showing which one gets bigger during the stutter if you can.
AnyOldName3, Master of Shadows

User avatar
psi29a
Posts: 4632
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Constant 60 FPS but annoying micro-stuttering

Post by psi29a » 20 Nov 2018, 13:37

Jerome89 wrote:
20 Nov 2018, 12:18
About textures mods, in both cases I'm using :
- HD Vanilla textures
- VanillaPlus textures mod (Purist version)
I'm noticing a trend here, if you disable those two mods... do you still get stuttering?

Jerome89
Posts: 8
Joined: 04 Oct 2018, 12:35

Re: Constant 60 FPS but annoying micro-stuttering

Post by Jerome89 » 20 Nov 2018, 23:37

Hello,

Thank you for your replies

@AnyOldName3 : I just can't take a damned screenshot while the debug diagrams (F3 and F4 screens) are displayed ! either using F12 or Windows default "print screen" button, the following paste in Paint is just black. Do you experience the same problem or do I need to buy a new set of hands ? :lol:

@AnyOldName3 : If I remove the VanillaPlus textures mod, indeed the problem is less annoying, but still there. Unfortunately, I can't easily remove the HD Vanilla textures because I didn't keep any backups of the game folder without this mod (only texture files) installed.

Another test : I played with OPENMW_PHYSICS_FPS global setting. With the value set to 30 (instead of default 60), stuttering is more annoying on 0.46 and latest 0.44, whereas it basically runs smoother on 0.44 official release, especially in crowded areas

vsync and physics are the only elements I played with having an impact on the stuttering

Jérôme

User avatar
Capostrophic
Posts: 659
Joined: 22 Feb 2016, 20:32

Re: Constant 60 FPS but annoying micro-stuttering

Post by Capostrophic » 21 Nov 2018, 06:35

F12 doesn't copy the image to the clipboard, and it's not meant to. It saves a screenshot to your openmw folder in Documents/My Games or .local/share depending on the OS.

Chris
Posts: 1559
Joined: 04 Sep 2011, 08:33

Re: Constant 60 FPS but annoying micro-stuttering

Post by Chris » 21 Nov 2018, 08:12

What exactly do you mean by micro-stuttering? Does the actual FPS drop slightly during the stutter, or is it a solid 60fps throughout and just looks/feels like it dropped a frame? Micro-stuttering is the latter, and there's not much that can be done about it right now since it's a result of the difference between GPU's render timing and the CPU's time measurement. The best you can try to do is lighten the GPU's load as much as possible so the timing discrepancy stays low.

The former is normal stuttering, and is usually caused by either a background process hogging the CPU for a moment (e.g. a virus scanner, or a web browser with a script-intensive webpage), or over-filling your system RAM or VRAM, causing resources to swap out to slower-access memory. The way to help with that is to turn off any unnecessary background processes while playing, and avoid mods that (all together) require more RAM/VRAM than you have available.

User avatar
psi29a
Posts: 4632
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Constant 60 FPS but annoying micro-stuttering

Post by psi29a » 21 Nov 2018, 09:40

That is why I said that the HD Vanilla (and other high-res texture replaces) might be an issue. We've seen in other threads people who have a buttery smooth experience with vanilla textures then go to 1K and 4K textures then see micro-stuttering happen.

Can you confirm that even with your mods that everything was 'fine' with the official 0.44 release?

We are about to release 0.45, would you be willing to test a 0.45 RC build as well?

This is on Windows right?

@fellow-devs: Could there be an issue with threads being joined (effectively blocking) causing a micro-stutter ever 5 seconds or so? We have threads for sound/music, cell-preloading and now navmesh generation. I wonder if bumping the navmash cache size up (using more RAM) would improve/reduce the micro-stutter? Or is this a dead-end?

Jerome89
Posts: 8
Joined: 04 Oct 2018, 12:35

Re: Constant 60 FPS but annoying micro-stuttering

Post by Jerome89 » 21 Nov 2018, 11:52

Hi everyone,

@Capostrophic : My bad, I'll send you a screenshot as soon as I'm back home

@Chris: During the stutter I'm talking about, I always get a solid and constant 60 FPS. I've been playing Open Morrowind for about 50 hours with zero stuttering except during some cells transition, along with a slight FPS drop in those rare cases. Since the latest 0.44 nightly builds releases, I'm experiencing this "new" stuttering, which indeed looks like it dropped a frame

@psi29a: yes I can confirm that everything was fine with the official 0.44 release. If I load my recent savegames with official 0.44 release instead of latest nightly builds, it's still fine. I'll give the 0.45 RC build a test as soon as I'm back home.

About my computer config :
Windows 10
16G RAM
NVIDIA GTX 1070 8G

User avatar
Capostrophic
Posts: 659
Joined: 22 Feb 2016, 20:32

Re: Constant 60 FPS but annoying micro-stuttering

Post by Capostrophic » 21 Nov 2018, 12:14

AFAIK Windows release and RC builds have some time-costly optimizations turned on during building so they can have better performance than nightly builds.

Argoon
Posts: 3
Joined: 09 Feb 2017, 16:45

Re: Constant 60 FPS but annoying micro-stuttering

Post by Argoon » 21 Nov 2018, 21:09

Jerome89 wrote:
20 Nov 2018, 12:18
Hello,

I need help to understand my problem :-) Most of the time, I get 60 FPS while playing with OpenMW. Nevertheless, every 5 or 6 seconds, I get some micro stuttering. Some more informations :
1. I'm playing using OpenMW nightly builds
2. This problem occurs since latests 0.44 nightly builds revisions (currently on 0.46, problem still occurs)
3. If I load a savegame from Seyda Neen (at the very beginning) and run off the city for 2 minutes :
- With official 0.44 release: no stuttering, 60 FPS, smooth cells transition
- With latest nightly build (or 13th of november 0.44 revision) : stuttering every 5 seconds, 60 FPS, smooth cells transition

In both cases, configuration file is the same (Normal maps are disabled, force_shaders is activated) and same mods are installed.

About textures mods, in both cases I'm using :
- HD Vanilla textures
- VanillaPlus textures mod (Purist version)

Also, I've tried playing with different v-sync settings :
- ingame v-sync
- Nvidia (1070 8GO) v-sync ON and ingame v-sync OFF
=> Problem is still there, maybe a little less noticeable with Nvidia v-sync

Can someone tells me what the problem might be ? i'm a bit lost, and the frequent micro-stuttering are really annoying

Jerome
Read this perhaps it explains what you are seeing and if is the culprit there's nothing the OpenMW team can do.

https://medium.com/@alen.ladavac/the-el ... 8f899aec92

Post Reply