FPS drops

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

FPS drops

Post by Johnny99 » 29 Sep 2018, 16:45

Hey guys, I still haven't been able to solve my FPS drops I experinece in OpenMW when traveling. My setup is: Ryzen 3 1300X, GTX 1060, 16GB RAM. OS: Windows 10 64-bit. All drivers are latest. Morrowind/OpenMW are both on SSD. Using no mods whatsoever - tried the Morrowind Optimization Patch once, it didn't make a difference. Here are some proper screenshots (unlike last time): https://imgur.com/a/bDhebKt

User avatar
akortunov
Posts: 433
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: FPS drops

Post by akortunov » 30 Sep 2018, 05:25

Reply from another thread:
Chris wrote:
01 Sep 2018, 14:47
Johnny99 wrote:
01 Sep 2018, 06:30
Yes I meant the first thing you said, unsmooth visuals despite a smooth framerate, especially in larger towns and rarely in the wilderness.
It's unlikely that any particular option will be able to fix it, since it's a result of the actual device rendering time not being synced to the system clock used for timing. Certain things may make the issue worse or more apparent, but there's no guaranteed way to handle it because hardware renders asynchronously to the game threads, and rendering APIs lack a way to get the real frame timing.

Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

Re: FPS drops

Post by Johnny99 » 30 Sep 2018, 06:35

Well, in that case I am doomed - no Morrowind for me. Sigh.

User avatar
lysol
Posts: 1064
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: FPS drops

Post by lysol » 30 Sep 2018, 06:57

I take it you've tried disabling v-sync?
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

Re: FPS drops

Post by Johnny99 » 30 Sep 2018, 09:20

akortunov wrote:
30 Sep 2018, 05:25
Reply from another thread:
Chris wrote:
01 Sep 2018, 14:47
Johnny99 wrote:
01 Sep 2018, 06:30
Yes I meant the first thing you said, unsmooth visuals despite a smooth framerate, especially in larger towns and rarely in the wilderness.
It's unlikely that any particular option will be able to fix it, since it's a result of the actual device rendering time not being synced to the system clock used for timing. Certain things may make the issue worse or more apparent, but there's no guaranteed way to handle it because hardware renders asynchronously to the game threads, and rendering APIs lack a way to get the real frame timing.
I was wrong, I do actually experience FPS drops.
lysol wrote:
30 Sep 2018, 06:57
I take it you've tried disabling v-sync?
The white line is absolutely smooth with VSync disabled, meaning no FPS drops, but then I miss the smoothness of VSync. :/

Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

Re: FPS drops

Post by Johnny99 » 02 Oct 2018, 14:45

Great support forum.

User avatar
lysol
Posts: 1064
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: FPS drops

Post by lysol » 02 Oct 2018, 15:47

Thanks for the sarcasm! You see, trying to help people while getting nothing in return is not that fun when you get a reply like this. Remember that no one here is paid and you paid nothing for this software.

My only recommendation, as a non-developer, would be to disable V-sync. I can't help you anymore than that, which is why I didn't reply anymore.
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

Re: FPS drops

Post by Johnny99 » 03 Oct 2018, 13:53

lysol wrote:
02 Oct 2018, 15:47
Thanks for the sarcasm! You see, trying to help people while getting nothing in return is not that fun when you get a reply like this. Remember that no one here is paid and you paid nothing for this software.

My only recommendation, as a non-developer, would be to disable V-sync. I can't help you anymore than that, which is why I didn't reply anymore.
Anytime.

User avatar
raevol
Posts: 2786
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: FPS drops

Post by raevol » 04 Oct 2018, 21:17

Let's keep it civil folks. Johnny99, I don't actually see an issue on your screenshots? Most of them have no FPS drops, and the few that do don't indicate any cause? For all we know your antivirus is spinning up in the background and stealing cpu cycles from the game?

Do you have any steps we can follow that reliably reproduce the issue? Because if not, it's not something we can help you with.

Johnny99
Posts: 14
Joined: 31 Aug 2018, 12:01

Re: FPS drops

Post by Johnny99 » 05 Oct 2018, 14:37

raevol wrote:
04 Oct 2018, 21:17
Let's keep it civil folks. Johnny99, I don't actually see an issue on your screenshots? Most of them have no FPS drops, and the few that do don't indicate any cause? For all we know your antivirus is spinning up in the background and stealing cpu cycles from the game?

Do you have any steps we can follow that reliably reproduce the issue? Because if not, it's not something we can help you with.
Lmao do you really not see the white line going up and down? Ok then.

Locked

Who is online

Users browsing this forum: No registered users and 3 guests