Page 2 of 2

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 19 Aug 2018, 01:06
by AnyOldName3
There seems to be a massive stall for no reason in the middle of that. Are you sure nothing weird's going on, such as you're running something else that's burning loads of CPU time or you've plugged your monitor into the motherboard instead of the new GPU?

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 19 Aug 2018, 01:14
by Capostrophic
There seems to be a massive stall for no reason in the middle of that.
That's both OSG updating the scene bounds and since F3 was pressed four times all the stuff (lots of it) in the scene being counted. OP should probably make another screenshot where View, Stateset etc. column isn't visible.

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 19 Aug 2018, 06:05
by rileyball2
Capostrophic wrote:
19 Aug 2018, 01:14
There seems to be a massive stall for no reason in the middle of that.
That's both OSG updating the scene bounds and since F3 was pressed four times all the stuff (lots of it) in the scene being counted. OP should probably make another screenshot where View, Stateset etc. column isn't visible.
https://imgur.com/gallery/QBUgAkp
Sorry didn't realize that could actually change anything

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 19 Aug 2018, 08:42
by Capostrophic
FYI you don't need to publish pictures on imgur to make them public, unless imgur changed something in that recently.

You may have brought your game to a crawl with the mods. With this Balmora expansion and Vurt's trees the "visual" threads and physics taking too long is somewhat understandable (though a GTX 1060 should have handled this with ease), but there's also something really wrong with scripting, which usually should take a miniscule amount of frametime. You can still try to run openmw with the integrated video chip and take a screenshot of the profiler, right?

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 19 Aug 2018, 17:05
by akortunov
rileyball2 wrote:
18 Aug 2018, 22:31
Yeah sorry just took the picture wherever I was in the game at the time. This one is in balmora near Caius Cosade's house
Judging by screenshot, your game is heavy-modded. Basically, if you have a decent CPU, you have two issues:
1. A lot of bad-designed scripts.
2. A lot of bad-designed complex collision meshes.
So obviously videocard upgrade will not make situation better, even if you will use a Titan.
Try do disable your mods one-by-one and find yout which mod causes a slowdown.

Re: Framerates haven't changed since installing better gpu (ubuntu 14.04)

Posted: 20 Aug 2018, 09:39
by psi29a
Would it be worth it to consider a 'mod' profiler? A way to manage and measure what kind of performance impact a mod has, how much resources it uses? That would be ideal for trying to improve existing mods and for creating new mods.