Openmw segfaults on tinkerboard

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
tinkerthinker
Posts: 2
Joined: 17 Jul 2018, 11:56
Github profile: https://github.com/pinilpypinilpy

Openmw segfaults on tinkerboard

Post by tinkerthinker » 17 Jul 2018, 12:18

Hi everyone. I've spent the last few days compiling openmw for the Asus tinkerboard, running stretch. Openmw runs slowly in software emulation, but it works. Then I tried to use gl4es to speed things up. The android port uses
Gl4es to hardware emulate OpenGL. I've tested gl4es on the tinkerboard with sauerbraten, and it works great (compiled for odroid, similar hardware, Mali gpu)

So, when I started openmw, the loading screen appeared for a few seconds, then openmw segfaulted with the start of the engine.
crash.log
Here is my crash.log
(40.42 KiB) Downloaded 14 times
Notes:
The tinkerboard doesn't support gles 1, but it supports 2 and 3. No support for OpenGL except with gl4es.

I compiled osg 3.6 (.2?) And the latest version of openmw from source

When I ran openmw with software emulation, there was no text, just a very small empty floating box ( in the game)

Thanks, tinkerthinker

User avatar
psi29a
Posts: 4195
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Openmw segfaults on tinkerboard

Post by psi29a » 17 Jul 2018, 12:38

OpenMW still has issues with OSG 3.6, but this I believe is a regression in 3.6 that is fixed in (soon?) 3.6.1, other devs, correct me if I'm wrong.

OpenMW works with OSG 3.4, when we make releases.. it's with that version.

If you would like to help improve support for gl4es, please do.

However there are no plans to have OpenMW support GLESv2/3 natively.

tinkerthinker
Posts: 2
Joined: 17 Jul 2018, 11:56
Github profile: https://github.com/pinilpypinilpy

Re: Openmw segfaults on tinkerboard

Post by tinkerthinker » 17 Jul 2018, 13:08

Currently I'm using (verified) OSG 3.6.2 stable. Maybe I should try running OpenMW with OSG 3.4 and see if that works.

However, the crash.log didn't mention problems with OSG.


Thanks, tinkerthinker

User avatar
akortunov
Posts: 392
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Openmw segfaults on tinkerboard

Post by akortunov » 17 Jul 2018, 13:17

tinkerthinker wrote:
17 Jul 2018, 13:08
OSG 3.6.2 stable.
Then I'd suggest to rebase the 3.6 branch of the OSG-on-steroids fork over 3.6.2 and check if there are any improvements.
Also it would be nice to test recent 3.4.x releases (IIRC, more recent version for now is 3.4.15).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests