Textures for fire (torches, fireplace, etc.) look very rudimentery

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
ethan
Posts: 3
Joined: 04 Jul 2018, 04:46
Github profile: https://github.com/Ethan-ks

Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by ethan » 17 Jul 2018, 08:02

First things first, OpenMW is an incredible feat! And made even more incredible in that its open source. I've got a strong interest in learning the ins and outs or game programming, particularly physics and rendering, and your project gives me an awesome project to sit and try to understand.

I'm having a minor but irritating issue. The game world looks great, all the textures are quite good, except for anything related to fire. I've included a screenshot for example. I'm running the latest build from source at the time of this posting. I am guessing its to due with the textures included in the data files, but interestingly running the same version of openmw on another computer in my house with a copy of the same datafiles, I get perfect fire textures!

Thanks in advance.
Fireplace
Image

EDIT: It looks like the blood textures are affected as well
Image

User avatar
psi29a
Posts: 4361
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by psi29a » 17 Jul 2018, 09:34

Looks like something driver related? Alpha transparency not being applied properly?

User avatar
akortunov
Posts: 469
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by akortunov » 17 Jul 2018, 09:36

Last time I encountered similar bug, it was the broken alpha calculation due to bug in OpenSceneGraph v3.5.1. Which OSG versions both your computers have?

ethan
Posts: 3
Joined: 04 Jul 2018, 04:46
Github profile: https://github.com/Ethan-ks

Re: Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by ethan » 17 Jul 2018, 14:44

You guys are quick, thanks!
akortunov wrote:
17 Jul 2018, 09:36
Last time I encountered similar bug, it was the broken alpha calculation due to bug in OpenSceneGraph v3.5.1. Which OSG versions both your computers have?
That looks like the problem, the affected computer is running osg v3.5.1, like you guessed. Before I installed from source I had installed the package maintained in the gentoo repos, which interestingly pulls in specifically OSG 3.5.1 as a dependency, so that was the osg I had installed on the system. I'm rebuilding 3.5.5 now, and I'll see if that does the trick. I'll probably just install the fork on the OpenMW repos when I have a little more time later on.

Thanks!

ethan
Posts: 3
Joined: 04 Jul 2018, 04:46
Github profile: https://github.com/Ethan-ks

Re: Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by ethan » 17 Jul 2018, 22:12

That was it, I built v3.5.5 of osg and now my textures are much better. Thanks, it was really distracting.
Keep up the good work!

silentthief
Posts: 305
Joined: 18 Apr 2013, 01:20
Location: Currently traversing the Ascadian Isles

Re: Textures for fire (torches, fireplace, etc.) look very rudimentery

Post by silentthief » 19 Jul 2018, 14:34

ethan wrote:
17 Jul 2018, 08:02
Image
Glad that this is working - but I wanted to say that that is a heck of a blood spray. What did you hit him with? :o

ST
"Hurry, hurry! Last boat to Solstheim! Until the next one. Hah-ha-hah."

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests