Textures and collision not loading

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
User avatar
akortunov
Posts: 332
Joined: 13 Mar 2017, 13:49
Location: Samara, Russian Federation
Github profile: https://github.com/akortunov

Re: Textures and collision not loading

Post by akortunov » 15 Jul 2018, 13:07

Cartifer wrote:
15 Jul 2018, 12:57
Is Qt only used for the launcher? If that's the case, there is still hope.
For launcher, editor and other external apps. Game itself does not use Qt.

K1ll
Posts: 138
Joined: 06 Aug 2011, 21:54

Re: Textures and collision not loading

Post by K1ll » 15 Jul 2018, 13:56

Cartifer wrote:
15 Jul 2018, 12:57
akortunov wrote:
15 Jul 2018, 05:33
Cartifer wrote:
13 Jul 2018, 13:45
"undefined symbol: _ZN9QListData11detach_growEPii".
Looks like Qt packages, installed on your system, have different version, than OpenMW requires.
For example, your system has Qt 4.6, but binary requires Qt 4.8.
That's unfortunate, because I don't have the rights to update Qt. I notice that when i run "openmw" instead of "openmw-launcher", I get another error message instead about "libopus.so.0" not existing. (I did notice that version 0.36 contains "libopus.so.0") Is Qt only used for the launcher? If that's the case, there is still hope.
Yeah i must've disabled packaging libopus when changing the scripts. Not sure why. I've now added it to the packages again and rebuild the RC2 packages. Just download them again and openmw should work.

I've also uploaded the qt4 libraries of my build machines here: Centos 6 Qt4
Just add the files in the lib directory from this targz to the lib directory in the openmw folder.

I'm not going to add qt4 to the packages directly since it bloats them up quite a bit and pretty much anything newer than CentOS 6 has qt 4.8+ anyway.

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 15 Jul 2018, 14:13

akortunov wrote:
15 Jul 2018, 13:07
Game itself does not use Qt.
That's good to hear. I have made some progress using "openmw". By preloading the missing "libopus.so.0" file, I can get the --help info to show up in the terminal:
Spoiler: Show

However, when i try to run without arguments, I get the following error:
Spoiler: Show
This is probably because I never ran "openmw-wizard". My "$HOME/.config/openmw" folder contains the file "openmw.cfg". It begins with
Spoiler: Show
has "fallback=X" in the middle, and ends with
Spoiler: Show
Can anyone spot anything wrong here?

Edit: I just refreshed and saw your post K1ll. I will try your solution immediately.

Cartifer
Posts: 11
Joined: 12 Jul 2018, 11:31

Re: Textures and collision not loading

Post by Cartifer » 15 Jul 2018, 14:24

Wizard, launcher, and game all work perfectly now. :D I only got one warning: "Warning: controller R2_Claw02 present more than once in meshes/r/xsiltstrider.kf, ignoring later version", but it has no impact on the game.

Thanks K1ll, akortunov, and psi! :)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests