Build Issues with VSC 2015

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
User avatar
Greendogo
Posts: 1374
Joined: 26 Aug 2011, 02:04

Build Issues with VSC 2015

Post by Greendogo » 25 Mar 2018, 06:25

I just reinstalled Windows and while trying to build the OpenMW with the installer I'm getting an MSB3073 error. The first of such errors looks like this:

Code: Select all

Severity	Code	Description	Project	File	Line	Suppression State
Error	MSB3073	The command "setlocal
"C:\Program Files\CMake\bin\cmake.exe" -DBUILD_TYPE=Release -P cmake_install.cmake
if %errorlevel% neq 0 goto :cmEnd
:cmEnd
endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
:cmErrorLevel
exit /b %1
:cmDone
if %errorlevel% neq 0 goto :VCEnd
:VCEnd" exited with code 1.	INSTALL	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppCommon.targets	133	
Any ideas on what is causing this and how to fix it? It's specifically just when I try to build the INSTALL project.

User avatar
AnyOldName3
Posts: 1032
Joined: 26 Nov 2015, 03:25

Re: Build Issues with VSC 2015

Post by AnyOldName3 » 25 Mar 2018, 14:11

I wouldn't bother with the install project. You've already got working executables before it works.
AnyOldName3, Master of Shadows

User avatar
Greendogo
Posts: 1374
Joined: 26 Aug 2011, 02:04

Re: Build Issues with VSC 2015

Post by Greendogo » 25 Mar 2018, 14:28

I understand why you'd say that, however my goal is to produce an installer, not just get the executables.

User avatar
Greendogo
Posts: 1374
Joined: 26 Aug 2011, 02:04

Re: Build Issues with VSC 2015

Post by Greendogo » 19 May 2018, 16:13

Bump, anyone there to help me get the installer building working? Where do I put all the dlls, for example?

User avatar
Ace (SWE)
Posts: 794
Joined: 15 Aug 2011, 14:56

Re: Build Issues with VSC 2015

Post by Ace (SWE) » 20 May 2018, 13:42

To get an installer you need to install NSIS and build the PACKAGE project, it'll grab all the DLLs from the Release folder to include in the installer.

It'll also look for a vcredist_[x86/x64].exe file in the solution folder that'll be baked in for installing the required Visual C++ redistributable.

I honestly don't think the INSTALL project has ever worked on Windows, not that I've personally tested it.

User avatar
Greendogo
Posts: 1374
Joined: 26 Aug 2011, 02:04

Re: Build Issues with VSC 2015

Post by Greendogo » 14 Jun 2018, 08:54

Thanks Ace, that worked! :D

User avatar
psi29a
Posts: 4077
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Build Issues with VSC 2015

Post by psi29a » 14 Jun 2018, 09:21

I've noticed on AppVeyor that we have constant failures with MSVC2015 but MSVC2017 _always_ works. There is something funky going on with logging output, so I'm not sure if is MSVC2015 or something AppVeyor or VM related.

Can we either set the AppVeyor to ignore the result of msvc2015 or can we just get rid of it all-together. Getting rid of it saves us having to wait for the build to complete before starting the msvc2017 build.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests