Trouble Installing on a Mac

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
silentDrew
Posts: 3
Joined: 16 Mar 2018, 18:33

Trouble Installing on a Mac

Post by silentDrew » 16 Mar 2018, 18:41

I'm trying to run OpenMW on a Mac, and I've gotten to the point where I have the OpenMW and OpenMW-CS files in my application folder, but the both crash immediately as soon as I try to run either of them. What else do I need to do before I can run them properly? I've tried searching around but I've found nothing.

silentDrew
Posts: 3
Joined: 16 Mar 2018, 18:33

Re: Trouble Installing on a Mac

Post by silentDrew » 16 Mar 2018, 19:10

Here's the error report that gets generated whenever I try to run the OpenMW file.
Process: openmw-launcher [822]
Path: /Users/USER/Desktop/*/OpenMW.app/Contents/MacOS/openmw-launcher
Identifier: openmw-launcher
Version: 0.43.0
Code Type: X86-64 (Native)
Parent Process: launchd [150]
User ID: 501

Date/Time: 2018-03-16 10:06:32.812 -0400
OS Version: Mac OS X 10.8.5 (12F45)
Report Version: 10

Interval Since Last Report: 468327 sec
Crashes Since Last Report: 14
Per-App Crashes Since Last Report: 7
Anonymous UUID: 2138734B-0D39-4B3E-7B41-2A662F4B110A

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Symbol not found: _kCTLanguageAttributeName
Referenced from: /Users/USER/Desktop/*/OpenMW.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/5/QtGui
Expected in: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
in /Users/USER/Desktop/*/OpenMW.app/Contents/MacOS/../Frameworks/QtGui.framework/Versions/5/QtGui
and then the rest seems to be data addresses that goes on for a long time.

silentDrew
Posts: 3
Joined: 16 Mar 2018, 18:33

Re: Trouble Installing on a Mac

Post by silentDrew » 16 Mar 2018, 20:47

UPDATE: I managed to get it to work by dowloading v0.34 instead. The more recent versions make use of obscure parts of Mac's "Core Text" library that aren't present on my version of OSX, which really should have been mentioned somewhere.

User avatar
raevol
Posts: 2594
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: Trouble Installing on a Mac

Post by raevol » 17 Mar 2018, 06:48

Thank you for following up- we don't have a large Mac user base, but I hope @corristo can take a look?

User avatar
Thunderforge
Posts: 262
Joined: 06 Jun 2017, 05:57
Github profile: https://github.com/Thunderforge

Re: Trouble Installing on a Mac

Post by Thunderforge » 17 Mar 2018, 23:41

I notice from the bug report that you're running macOS 10.8. The latest versions work fine for me on macOS 10.13. I suppose we've never said what the minimum version that OpenMW supports is, but I think most devs are running the latest.
silentDrew wrote:
16 Mar 2018, 20:47
The more recent versions make use of obscure parts of Mac's "Core Text" library that aren't present on my version of OSX, which really should have been mentioned somewhere.
Looking at the stack trace, the issue is that Qt 5 is looking for a dynamic library that isn't present. According to the Qt's supported platforms page, Qt 5.6 (LTS) supports macOS 10.8, but Qt 5.9 (LTS), which is the next supported version, only supports macOS 10.10 and later.

So I guess we would need to either ensure that builds are built with Qt 5.6, allowing compatibility down to macOS 10.8, or insist on using Qt 5.9 and lose support for it. In either case, it ought to be documented.

For what it's worth, as of February 2018, 91.36% of worldwide Mac users are using macOS 10.10 or newer. 96.59% of Mac users are using 10.8 or newer, meaning that supporting that version would enable 5.23% more users to play.

User avatar
AnyOldName3
Posts: 720
Joined: 26 Nov 2015, 03:25

Re: Trouble Installing on a Mac

Post by AnyOldName3 » 18 Mar 2018, 00:57

It's also possible to build OpenMW with Qt 4, so it's not like we're stuck with the latest version only.
AnyOldName3, Master of Shadows

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests