Page 1 of 1

No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 17:01
by trackpadtimmy
Using a MacBook Air 11inch from early 2015.

There's no dialogue in game from Jiub or the guard, and nothing to input my name. All that happens is the guard walks down and stares at me. I can't interact with any objects either. There also doesn't appear to be any in game sound other than the background music, since I can't hear the footsteps of the guard walking. My sound is enabled and turned up in game.

Re: No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 19:44
by Thunderforge
Which version of OpenMW are you using? Where did you get the copy of Morrowind (Steam, GoG, retail CD, etc)? And do you have any mods loaded?

Re: No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 19:55
by trackpadtimmy
I am using OpenMW 0.43.0, I got Morrowind from Steam, and I don't have any mods loaded.

Re: No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 20:01
by Thunderforge
Out of curiosity, is there any lip movement? And does the guard eventually walk away at the point where he’s supposed to be done saying his lines?

Re: No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 20:09
by trackpadtimmy
No lip movement at all, nor any subtitles showing up. I'm not sure how long the guard is supposed to be there but I waited for a couple minutes and nothing happened.

Re: No dialogue or menu popups when starting new game

Posted: 06 Feb 2018, 22:14
by Thunderforge
He says a line or two before saying “Follow me” and starts walking. That all happens within 10 seconds of his approach.

Can you open the console? It’s the ` key (the shift version is ~) on QWERTY keyboards. Not sure if the user can open it during that scene when their controls are usually disabled.

If not, then check the log files and see if an error is being logged.

Re: No dialogue or menu popups when starting new game

Posted: 07 Feb 2018, 01:54
by trackpadtimmy
I didn't see anything in the console, so I checked the log file and saw these errors:

Code: Select all

Execution of script Sound_Boat_Hull failed:
Resource 'sound/fx/envrn/boat_waves.mp3' not found
Execution of script CharGenNameNPC failed:
Resource 'sound/vo/misc/chargenname1.mp3' not found
Error handling text key soundgen: right: Resource 'sound/fx/foot/walkr_lt.mp3' not found
Error handling text key soundgen: left: Resource 'sound/fx/foot/walkl_lt.mp3' not found
Error handling text key soundgen: right: Resource 'sound/fx/foot/walkr_lt.mp3' not found
Error handling text key soundgen: left: Resource 'sound/fx/foot/walkl_lt.mp3' not found
Error handling text key soundgen: right: Resource 'sound/fx/foot/walkr_lt.mp3' not found
I installed OpenMW on another computer and it worked just fine on the other one. I compared the size of the fx folders on both and the one on my MacBook was way smaller. I copied the fx folder over and replaced the old one, and when I launched the game I could hear the footsteps of the guard and the creaking of the ship hull, but no voices. I figured out that the Vo folder probably stood for "Voices" so I decided to check the size of it, and it was way smaller again. Copied it over, replaced it, and now everything works. Voices play, subtitles show, lips move, and the name menu pops up.

I guess it might've been something with how I downloaded, or maybe when I transferred the files over because it seems really strange that those files were just missing. But it's all fixed now, so it's all good.

Re: No dialogue or menu popups when starting new game

Posted: 07 Feb 2018, 19:02
by Thunderforge
Glad to hear it’s working! Guess you had a bad Steam download or something.