Cmake Errors

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
TimMB
Posts: 10
Joined: 04 Jul 2017, 00:05
Github profile: https://github.com/tmbutterworth

Cmake Errors

Post by TimMB » 13 Nov 2017, 20:53

There are a lot of legacy Cmake 2.x errors appearing while running cmake. adding `cmake_policy(SET CMP0043 OLD)` to the top of each CMakeLists.txt file that still uses the depreciated syntax will allow it to work without error but these will have to be eventually ported to CMake 3.x as the legacy support will eventually be removed.

CMake Warning (dev) in apps/wizard/CMakeLists.txt:
Policy CMP0043 is not set: Ignore COMPILE_DEFINITIONS_<Config> properties.
Run "cmake --help-policy CMP0043" for policy details. Use the cmake_policy
command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) in apps/wizard/CMakeLists.txt:
Policy CMP0043 is not set: Ignore COMPILE_DEFINITIONS_<Config> properties.
Run "cmake --help-policy CMP0043" for policy details. Use the cmake_policy
command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) in apps/wizard/CMakeLists.txt:
Policy CMP0043 is not set: Ignore COMPILE_DEFINITIONS_<Config> properties.
Run "cmake --help-policy CMP0043" for policy details. Use the cmake_policy
command to set the policy and suppress this warning.
This warning is for project developers. Use -Wno-dev to suppress it.

User avatar
scrawl
Posts: 2085
Joined: 18 Feb 2012, 11:51
Contact:

Re: Cmake Errors

Post by scrawl » 13 Nov 2017, 20:57

Which OpenMW version are you talking about? As of current master, CMake 3.1 is the required minimum. Does this solve the issue?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests