Every texture is pink

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
ssccsscc
Posts: 3
Joined: 30 Aug 2017, 17:07

Every texture is pink

Post by ssccsscc » 30 Aug 2017, 17:22

I am compiled it for windows.

Have all libraries from there(+osg and raknet): https://wiki.openmw.org/index.php?title ... 012.2F2013

Console output:

Code: Select all

Warning: detected OpenGL error 'invalid operation at after RenderBin::draw(..)'
Warning: RenderBin "DepthClear" implementation not found, using default RenderBin as a fallback
In game everything works well, but all textures is just pink.

What can be done to fix this?
And is there any new instruction for compiling on windows?

User avatar
lysol
Posts: 726
Joined: 26 Mar 2013, 01:48
Location: Sweden

Re: Every texture is pink

Post by lysol » 31 Aug 2017, 12:20

Pink textures usually means that textures either aren't found or that they can't be decompressed (the textures are compressed with S3TC compression). Try updating your graphics card drivers maybe?
Normal mapped texture replacers, exclusive for OpenMW:
My Nexus page

ssccsscc
Posts: 3
Joined: 30 Aug 2017, 17:07

Re: Every texture is pink

Post by ssccsscc » 31 Aug 2017, 13:23

lysol wrote:
31 Aug 2017, 12:20
Pink textures usually means that textures either aren't found or that they can't be decompressed (the textures are compressed with S3TC compression). Try updating your graphics card drivers maybe?
I am using Nvidia GTX 760 with latest drivers. I think its problem with dependencies, but I downloaded they from wiki pages.

User avatar
psi29a
Posts: 3449
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Every texture is pink

Post by psi29a » 31 Aug 2017, 15:47

If you are using the nvidia binary drivers, then the textures are passed directly to the card for decoding... this doesn't happy by default with the open-source nvidia modules.

ssccsscc
Posts: 3
Joined: 30 Aug 2017, 17:07

Re: Every texture is pink

Post by ssccsscc » 31 Aug 2017, 16:16

I am fixed that problem by recompilling with OSG downloaded from there http://www.lysator.liu.se/~ace/OpenMW/d ... 5-win64.7z

User avatar
psi29a
Posts: 3449
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Every texture is pink

Post by psi29a » 31 Aug 2017, 17:13

Good job. :)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest