Performance Issues

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
cburgheimer
Posts: 4
Joined: 19 Jul 2017, 00:01

Performance Issues

Post by cburgheimer » 19 Jul 2017, 00:32

I seem to be getting some pretty major performance issues with OpenMW, the average framerate is around 15-20 FPS in Seyda Neen. If i could get some help sorting this issue out it would be greatly appreciated.

My Specs are listed in the first attachment, and i included a screenshot in the second attachment.

I'm running these mods:
Better Dialogue Fonts
Better Bodies
Better Clothes
Better Heads
Better Sounds
Birthsigns are More Fun
Ilys Solsteim Rumour Fix
Imperial Forts Normal Mapped
LGNPC No Dialogue Merged
Lysol's Guar Skin Banners Normal Mapped
Lysol's Hlaalu Normal Mapped
Lysol's Imperial Towns Normal Mapped
Lysol's Vivec Normal Mapped
Morrowind Rebirth
Official Mods Compilation
Races are More Fun
Real Signposts
Sneak Tools
Tamriel Rebuilt
The Redguard Rug

Running these settings:

[Video]
resolution x = 1920
resolution y = 1080
fullscreen = true

antialiasing = 0
vsync = false
window border = false

gamma = 1.38976

[General]
anisotropy = 16
texture mipmap = linear

[Water]
reflect actors = true
refraction = true
rtt size = 2048
shader = true

[Camera]
viewing distance = 10000

field of view = 80.205

small feature culling pixel size = 16.0

[Cells]
exterior cell load distance = 2

[Terrain]
distant terrain = True

[GUI]
menu transparency = 0.881788
subtitles = true

[Input]
always run = true

[Sound]
music volume = 0.255526
Attachments
DxDiag.txt
(79.66 KiB) Downloaded 18 times
screenshot000.png

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Performance Issues

Post by psi29a » 19 Jul 2017, 08:30

What version of OpenMW?

User avatar
DestinedToDie
Posts: 1058
Joined: 29 Jun 2015, 09:08

Re: Performance Issues

Post by DestinedToDie » 19 Jul 2017, 08:51

I would turn off distant terrain because at 10000 view distance and 2 cells loaded you are hindering your performance without seeing any benefit. Also check console, error spam could be dragging your performance down. Something like having to print an error message at every frame of the game can have an impact.

User avatar
scrawl
Posts: 2085
Joined: 18 Feb 2012, 11:51
Contact:

Re: Performance Issues

Post by scrawl » 19 Jul 2017, 15:58

With an AMD CPU and GPU, which is the worst combo to play OpenMW on (since their OpenGL drivers are CPU-heavy, and the low IPC of the CPU makes it even slower), rather extreme settings (high FOV, extended cell grid, actor reflections), and a shit ton of who-knows-how-inefficient mods - yeah, that FPS number is about what I would expect.

What do you get with the default cell load distance of 1?

Turning off distant terrain will probably not make it much faster, or at all; the terrain is more GPU heavy than CPU heavy, also, the "non distant" terrain engine uses no LOD at all so it might actually be slower in some cases.

cburgheimer
Posts: 4
Joined: 19 Jul 2017, 00:01

Re: Performance Issues

Post by cburgheimer » 19 Jul 2017, 23:11

Okay, thank you guys for your advice i'll see what happens when i change the settings that you guys recommended. I also deactivated all of my mods, so ill hopefully get back to you guys on those in a few.
I was originally playing on OpenMW 0.41, but i had these exact same problems and i ended up stumbling upon the RC builds of 0.42. So i'm using those right now currently.

cburgheimer
Posts: 4
Joined: 19 Jul 2017, 00:01

Re: Performance Issues

Post by cburgheimer » 19 Jul 2017, 23:18

Okay i tried out the changes you guys recommended and was able to get around 35-40 on average when looking at Seyda Neen.

Chris
Posts: 1297
Joined: 04 Sep 2011, 08:33

Re: Performance Issues

Post by Chris » 20 Jul 2017, 05:37

Did you install your drivers from AMD's site, or what MS provided? MS provided drivers can likely cause performance issues for OpenGL apps, so it may help if you install drivers direct from AMD.

cburgheimer
Posts: 4
Joined: 19 Jul 2017, 00:01

Re: Performance Issues

Post by cburgheimer » 20 Jul 2017, 06:28

I always use the drivers from AMD itself, i even updated them today actually. But i think i figured out what the problem was. It seems that Morrowind Rebirth drops the average fps by about 15 fps, which is extremely weird as Morrowind Rebirth's nexus page and Moddb page both say it is compatible with OpenMW.

User avatar
Pherim
Posts: 139
Joined: 27 Aug 2014, 15:37

Re: Performance Issues

Post by Pherim » 20 Jul 2017, 11:45

Compatible doesn't mean it has no performance impact... As far as I know, Rebirth adds a lot of objects to the game world, which of course is going to cost you some FPS.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests