Debian 9 (Stretch)

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
looniks
Posts: 3
Joined: 08 Jul 2017, 17:45

Debian 9 (Stretch)

Post by looniks » 08 Jul 2017, 17:49

Hey guys!

Average Linux user here! (Debian 9, a.k.a. "Stretch").

Just recently found out my all time favorite game is playable on Linux through your amazing project OpenMW. Gave installing it a shot (tried building from source) but failed because of bullet physics version outdated. From what I can tell OpenMW requires v. 286 (at least the latest OpenMW does) and Debian 9 only has 283.

Has anyone managed installing under Debian 9?

Thanks in advance! :mrgreen:

Edit: hope this question hasn't been answered before, tried searching your forums but no results.

User avatar
psi29a
Posts: 3480
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Debian 9 (Stretch)

Post by psi29a » 08 Jul 2017, 19:58

Have you tried experimental? bullet (2.86.1+dfsg-1)

https://packages.debian.org/source/experimental/bullet

You don't have to switch your install to that, just download the necessary packages and use dpkg to install.

looniks
Posts: 3
Joined: 08 Jul 2017, 17:45

Re: Debian 9 (Stretch)

Post by looniks » 09 Jul 2017, 13:41

Thanks for your reply!

I got past the Bullet-error by downloading and compiling the source.

Now the compiler gives me:

Code: Select all

[  0%] Linking CXX static library libosg-ffmpeg-videoplayer.a
[  0%] Built target osg-ffmpeg-videoplayer
[  1%] Linking CXX static library libosgQt.a
[  1%] Built target osgQt
Makefile:127: recipe for target ”all” failed
make: *** [all] Error 2
Guessing it's got something to do with openscenegraph?

EDIT: Nevermind, turns out my openscenegraph version is what is required (3.4). No idea what is causing this error :geek:

User avatar
damiel
Posts: 29
Joined: 16 Apr 2016, 11:46

Re: Debian 9 (Stretch)

Post by damiel » 09 Jul 2017, 18:53

Can you please provide the full output of the build rather then just the parts you think might be relevant? Because to me it seems the problem appeared already before the part that you posted. :)

User avatar
psi29a
Posts: 3480
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Debian 9 (Stretch)

Post by psi29a » 10 Jul 2017, 08:47

You didn't need to compile bullet from scratch, you just needed to download the debs:
https://packages.debian.org/experimental/libbullet-dev

the packages per arch are located near the bottom of the page.

looniks
Posts: 3
Joined: 08 Jul 2017, 17:45

Re: Debian 9 (Stretch)

Post by looniks » 11 Jul 2017, 20:58

Thank you for your replies!

Got it working by building bullet 2.86 and then installing the debs from sid (after downloading from the Debian site).

Now I can play my favorite game again!

Thanks guys! :D :D

User avatar
psi29a
Posts: 3480
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Debian 9 (Stretch)

Post by psi29a » 12 Jul 2017, 08:35

Cheers!

drpurpul
Posts: 10
Joined: 24 Dec 2017, 13:41
Github profile: http://github.com/andras-kiss

Re: Debian 9 (Stretch)

Post by drpurpul » 24 Dec 2017, 13:44

Managed to start compiling by installing bullet from the experimental. But won't it create a frankendebian system? Thank you for making openmw! This project is so great. I wish I could program better to participate...

drpurpul
Posts: 10
Joined: 24 Dec 2017, 13:41
Github profile: http://github.com/andras-kiss

Re: Debian 9 (Stretch)

Post by drpurpul » 24 Dec 2017, 14:04

I get this error however:

Code: Select all

akiss@debian:~/openmw/build$ make
[  0%] Built target osg-ffmpeg-videoplayer
[  0%] Built target local_tinyxml
[  1%] Built target oics
[  2%] Built target osgQt
-- OpenMW version 0.43.0
[  2%] Built target git-version
[ 24%] Built target components
[ 24%] Linking CXX executable ../../openmw
/usr/local/lib/libSDL2.so: error adding symbols: File in wrong format
collect2: error: ld returned 1 exit status
apps/openmw/CMakeFiles/openmw.dir/build.make:6535: recipe for target 'openmw' failed
make[2]: *** [openmw] Error 1
CMakeFiles/Makefile2:437: recipe for target 'apps/openmw/CMakeFiles/openmw.dir/all' failed
make[1]: *** [apps/openmw/CMakeFiles/openmw.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
akiss@debian:~/openmw/build$ 

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests