Cant start OpenMW through Steam

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
Falc
Posts: 24
Joined: 18 Jun 2017, 22:14

Cant start OpenMW through Steam

Post by Falc » 18 Jun 2017, 22:19

I am running Linux Mint 18.1 xfce.

OpenMW runs fine when I start it from the applications menu. However I want to use my steam controller in OpenMW, which means I have to start it through the steam client.

When I start OpenMW through the steam client, the launcher starts up fine, but when I click 'Play' in the launcher, I get this error message: "Could not initialise SDL! Could not initialise UDEV".

Could anyone suggest a fix?

User avatar
Thunderforge
Posts: 500
Joined: 06 Jun 2017, 05:57

Re: Cant start OpenMW through Steam

Post by Thunderforge » 19 Jun 2017, 05:27

Does this error happen immediately upon clicking "Play"? Do you see the Bethesda logo or does the error happen before that? That might give some insight into whether the error is with the launcher or the engine.

Falc
Posts: 24
Joined: 18 Jun 2017, 22:14

Re: Cant start OpenMW through Steam

Post by Falc » 19 Jun 2017, 07:55

The error happens immediately after clicking play, the Bethesda logo doesn't appear

abelthorne
Posts: 12
Joined: 28 Jun 2017, 14:17

Re: Cant start OpenMW through Steam

Post by abelthorne » 28 Jun 2017, 17:08

I have the same issue: the launcher works but Steam displays the error as soon as hitting "play" or by creating a shortcut for openmw rather than openmw-launcher. I think it might be related to the way Steam handles its runtime (the package of libs bundled with it) which, if I'm not mistaken, has been disabled by default a few monthes ago because it had issues with some graphic (Mesa) libs. I assume that it doesn't initialize SDL and OpenMW can't run because of this.

I've tried running Steam by forcing the runtime to load (STEAM_RUNTIME=1 steam) but in that case, while the error message doesn't appear anymore, OpenMW still doesn't launch, it just does nothing.

Not sure if it's related but Iv'e noticed a similar issue with OpenMW when trying a Wayland session a few days ago because it has issues with SDL that have to be bypassed by manually setting the SDL_VIDEODRIVER env var. It was not needed for ScummVM which, AFAIK, uses SDL too. It might be a clue, it seems that OpenMW needs a specific way of initializing SDL or something like that.

I won't really bother because I don't really need to run OpenMW through Steam but Falc can try the following in a terminal:

Code: Select all

export SDL_VIDEODRIVER=x11
steam
And check if it works. If not, try setting the runtime:

Code: Select all

export SDL_VIDEODRIVER=x11
STEAM_RUNTIME=1 steam
This is if you're using X.org (which should be the default on your Mint session). If you use Wayland, replace x11 by wayland for the SDL_VIDEODRIVER value.

I doubt it'll work but it's worth trying. As a workaround, you can also try this to use your Steam controller without Steam. There might be other ways to do it.

Falc
Posts: 24
Joined: 18 Jun 2017, 22:14

Re: Cant start OpenMW through Steam

Post by Falc » 02 Jul 2017, 21:22

Thanks for your reply, its good to know its not just me with this issue. Unfortunately that code didn't fix it, but I'll have a look at using the steam controller without steam as a workaround.

abelthorne
Posts: 12
Joined: 28 Jun 2017, 14:17

Re: Cant start OpenMW through Steam

Post by abelthorne » 04 Jul 2017, 09:23

Just in case, there seems to be other ways to use your Steam controller that the Github project I've linked to (and which seems a bit complictaed to install). Probably check this one first, it has a GUI and a deb package for easy installation on Ubuntu / Mint.

Post Reply