(Solved) Why does Bloodmoon.esm require Tribunal.esm?

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
Allofich
Posts: 104
Joined: 28 May 2016, 12:50

(Solved) Why does Bloodmoon.esm require Tribunal.esm?

Post by Allofich » 09 Mar 2017, 12:49

Looks like this was intentionally added.

https://bugs.openmw.org/projects/openmw ... cdd0957cdd

The original engine does not require Tribunal.esm for Bloodmoon.esm. In fact as I was playing Bloodmoon.esm I chose to play with only that and Morrowind.esm loaded because I saw in the Morrowind readme that "the Tribunal and
Bloodmoon master files are designed to only be dependent on the Morrowind master file -- and not each other." I know that there are warning messages that appear when loading them both, and although these aren't supposed to be a problem, I just wanted to be safe and avoid data conflicts.

So, I was thinking of filing a bug, but I found that this change was intentionally added. Anyone know why?

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by scrawl » 09 Mar 2017, 17:02

Because if you load both, the load order has to be Bloodmoon.esm last. The author of that change did not consider players that only have one of the expansions.

Allofich
Posts: 104
Joined: 28 May 2016, 12:50

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by Allofich » 09 Mar 2017, 17:15

OK, well I have both expansions, but I just chose to load only the Bloodmoon.esm. It seems to me like it should also be possible to do it in OpenMW. Maybe we could just have them be automatically loaded with Tribunal first if they are both selected for loading.

Also it sounds like the comment in the code there that "Bloodmoon.esm requires Tribunal.esm" is inaccurate. I know for sure, at least, that it's not required to have both loaded to play Bloodmoon in the original engine. I went all the way through the Bloodmoon quests without any missing resources or anything like that.

User avatar
AnyOldName3
Posts: 1495
Joined: 26 Nov 2015, 03:25

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by AnyOldName3 » 09 Mar 2017, 17:27

This really looks like information that something like LOOT or BOSS should be handling, not OpenMW (unless we build-in a plugin sorter).

That said, every computer or fresh install of OpenMW I've used has automatically placed Bloodmoon before Tribunal, so users who're just clicking away at things without knowing what they're doing are likely to get caught with their pants down if we leave it doing nothing.
AnyOldName3, Master of Shadows

Allofich
Posts: 104
Joined: 28 May 2016, 12:50

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by Allofich » 09 Mar 2017, 18:55

That said, every computer or fresh install of OpenMW I've used has automatically placed Bloodmoon before Tribunal
Were they Steam installations? The .esm files are ordered by date modified, and with Steam the .esm files will be dated for when you installed from Steam, Bloodmoon then comes before Tribunal due to alphabetical order I believe. With the original dates of the files from the CD installations they should have been ordered correctly, since Bloodmoon was released after Tribunal.

User avatar
AnyOldName3
Posts: 1495
Joined: 26 Nov 2015, 03:25

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by AnyOldName3 » 09 Mar 2017, 19:02

Before I'd ever run it, I copied my steam install of Morrowind to an external drive, and that's what I usually run OpenMW from on other computers. That would work as you said.
AnyOldName3, Master of Shadows

User avatar
Jyby
Posts: 408
Joined: 10 Dec 2013, 04:16

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by Jyby » 07 May 2017, 14:38

Allofich wrote:I just chose to load only the Bloodmoon.esm. It seems to me like it should also be possible to do it in OpenMW.
Did you chose this out of fear for the Dark Brotherhood? You can get them to stop attacking ya know. http://en.uesp.net/wiki/Tribunal:Dark_B ... od_Attacks
AnyOldName3 wrote:Before I'd ever run it, I copied my steam install of Morrowind to an external drive, and that's what I usually run OpenMW from on other computers. That would work as you said.
Yeah, I have a zipped up copy of my install because I usually play on my mac. Handy to have a backup as well if you're modding,

Moved to Support
Macbook Air 2013 - 1.7GHz Intel i7 - 8 GB - 512 GB SSD - Intel HD 5000
Windows 10 PC - 4GHz Intel i7 - 16 GB - 512 GB SSD - EVGA GTX 1060 SSC

User avatar
wareya
Posts: 337
Joined: 09 May 2015, 13:07

Re: Why does OpenMW make Bloodmoon.esm require Tribunal.esm?

Post by wareya » 07 May 2017, 16:48

Tribunal's esm fixes a few problems with Morrowind's esm. You should really have it enabled even if you're not doing the Tribunal quest.
paying attention to #1751 #2473 #3609 #3862/#3929 #3807 #4297 #4623

Post Reply