Can't install 0.41, no libopenthreads14

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
jiawen
Posts: 5
Joined: 22 Feb 2016, 09:57

Can't install 0.41, no libopenthreads14

Post by jiawen » 28 Feb 2017, 16:05

I have had 0.40 working quite happily on my Linux Mint 17.3 system for a while. When I saw that the 0.41 update had come up in my update manager, I decided to install it. Only now have I finally had time to see what's new... and only now do I discover that OpenMW has uninstalled altogether. When I bring it up in the Software Manager, it displays as "unavailable", and when I try to install from the console, I get:
sudo apt-get install openmw openmw-launcher
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openmw : Depends: libopenthreads14 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Note that those errors are after adding the OpenMW PPA.

What else should I try? Is it possible to revert to 0.40?

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Can't install 0.41, no libopenthreads14

Post by psi29a » 28 Feb 2017, 16:31

Did you upgrade your linux mint? What version does your mint correspond to ubuntu?

looks like you have some conflict between what is provided by mint and what is on the PPA.

you can use ppa-purge ppa:openmw/openmw to remove anything having to do with our PPA. Then you can use your distro's version of OpenMW.

Update: that version is based on Trusty, which is what our builds are based on for travis-ci.

Can you try to manually `apt install libopenthreads14` and post what it says when you try to do that?

jiawen
Posts: 5
Joined: 22 Feb 2016, 09:57

Re: Can't install 0.41, no libopenthreads14

Post by jiawen » 01 Mar 2017, 18:11

Here's what I get:
sudo apt-get install libopenthreads14
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libarmadillo4 libarpack2 libavcodec-ffmpeg56 libavdevice-ffmpeg56
libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
libavutil-ffmpeg54 libboost-program-options1.54.0 libboost1.54-dev libbs2b0
libbullet2.85 libbulletcollision2.83v5 libcoin80 libdap11 libdapclient3
libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1 libgraphicsmagick3
libhdf4-0-alt libhdf5-7 libkml0 liblinearmath2.83v5 libmyguiengine3
libmyguiengine3debian1v5 libnetcdfc7 libodbc1 libogdi3.2
libpostproc-ffmpeg53 libproj0 libsdl2-2.0-0 libspatialite5 libstdc++-4.8-dev
libswresample-ffmpeg1 libswscale-ffmpeg3 liburiparser1 libxerces-c3.1
libxine2 libxine2-bin libxine2-ffmpeg libxine2-misc-plugins libxine2-plugins
proj-data
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
libopenscenegraph-3.4-130 libopenthreads20
The following NEW packages will be installed:
libopenthreads14
0 upgraded, 1 newly installed, 2 to remove and 13 not upgraded.
Need to get 12.8 kB of archives.
After this operation, 29.6 MB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/universe libopenthreads14 amd64 3.2.0~rc1-4ubuntu0.1 [12.8 kB]
Fetched 12.8 kB in 0s (63.8 kB/s)
(Reading database ... 280198 files and directories currently installed.)
Removing libopenscenegraph-3.4-130:amd64 (3.4.0+dfsg1-4+openmw1~trusty2) ...
Removing libopenthreads20 (3.4.0+dfsg1-1~trusty8) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
Selecting previously unselected package libopenthreads14.
(Reading database ... 280061 files and directories currently installed.)
Preparing to unpack .../libopenthreads14_3.2.0~rc1-4ubuntu0.1_amd64.deb ...
Unpacking libopenthreads14 (3.2.0~rc1-4ubuntu0.1) ...
Setting up libopenthreads14 (3.2.0~rc1-4ubuntu0.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
me@thiscomputer~ $ sudo apt-get install openmw
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package openmw is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'openmw' has no installation candidate
me@thiscomputer~ $
After this, there was no candidate for OpenMW in the official repositories, so I re-added the PPA. After this, I was able to install OpenMW:
sudo apt-get install openmw openmw-launcher
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libboost1.54-dev libbulletcollision2.83v5 liblinearmath2.83v5
libmyguiengine3 libstdc++-4.8-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libopenscenegraph-3.4-130
The following NEW packages will be installed:
libopenscenegraph-3.4-130 openmw openmw-launcher
0 upgraded, 3 newly installed, 0 to remove and 14 not upgraded.
Need to get 9,572 kB of archives.
After this operation, 42.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/openmw/openmw/ubuntu/ trusty/main libopenscenegraph-3.4-130 amd64 3.4.0+dfsg1-4+openmw1~trusty3 [5,930 kB]
Get:2 http://ppa.launchpad.net/openmw/openmw/ubuntu/ trusty/main openmw amd64 0.41.0-1+openmw~trusty3 [2,641 kB]
Get:3 http://ppa.launchpad.net/openmw/openmw/ubuntu/ trusty/main openmw-launcher amd64 0.41.0-1+openmw~trusty3 [1,001 kB]
Fetched 9,572 kB in 3min 58s (40.1 kB/s)
Selecting previously unselected package libopenscenegraph-3.4-130:amd64.
(Reading database ... 280066 files and directories currently installed.)
Preparing to unpack .../libopenscenegraph-3.4-130_3.4.0+dfsg1-4+openmw1~trusty3_amd64.deb ...
Unpacking libopenscenegraph-3.4-130:amd64 (3.4.0+dfsg1-4+openmw1~trusty3) ...
Selecting previously unselected package openmw.
Preparing to unpack .../openmw_0.41.0-1+openmw~trusty3_amd64.deb ...
Unpacking openmw (0.41.0-1+openmw~trusty3) ...
Selecting previously unselected package openmw-launcher.
Preparing to unpack .../openmw-launcher_0.41.0-1+openmw~trusty3_amd64.deb ...
Unpacking openmw-launcher (0.41.0-1+openmw~trusty3) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Setting up libopenscenegraph-3.4-130:amd64 (3.4.0+dfsg1-4+openmw1~trusty3) ...
Setting up openmw (0.41.0-1+openmw~trusty3) ...
Setting up openmw-launcher (0.41.0-1+openmw~trusty3) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
So, that part worked. However, when I actually try to open OpenMW, I get this error:
openmw-launcher
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/me/.config/fontconfig/fonts.conf manually
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Loading config file: launcher.cfg
Loading config file: /home/me/.config/openmw/launcher.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
QFile::setFileName: File (/home/me/.config/openmw/openmw.cfg) is already opened
Loading config file: ./openmw.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
Loading settings file: /home/me/.config/openmw/settings.cfg
The current profile is: "2016-11-25T22:17:56"
./openmw: error while loading shared libraries: libOpenThreads.so.20: cannot open shared object file: No such file or directory
I tried re-running the install script to re-locate my Morrowind.esm file, and I end up with a slightly different error:
openmw-launcher
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/me/.config/fontconfig/fonts.conf manually
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
Loading config file: launcher.cfg
Loading config file: /home/me/.config/openmw/launcher.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
QFile::setFileName: File (/home/me/.config/openmw/openmw.cfg) is already opened
Loading config file: ./openmw.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
The current profile is: "2017-03-02T01:03:10"
Loading config file: launcher.cfg
Loading config file: /home/me/.config/openmw/launcher.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading config file: /etc/openmw/openmw.cfg
QFile::setFileName: File (/home/me/.config/openmw/openmw.cfg) is already opened
Loading config file: ./openmw.cfg
Loading config file: /home/me/.config/openmw/openmw.cfg
Loading settings file: /etc/openmw/settings-default.cfg
The current profile is: "2017-03-02T01:03:10"
./openmw: error while loading shared libraries: libOpenThreads.so.20: cannot open shared object file: No such file or directory
So, regardless of where I open it from, ./openmw is calling libOpenThreads.so.20 , even though I had to manually uninstall that and install openthreads14 in its place. I looked at the various .cfg files in both /home/me/.config/openmw/ and in /etc/openmw/ , and I couldn't find any mention of OpenThreads, so it looks like the problem is within ./openmw itself (?). What should I try next?

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Can't install 0.41, no libopenthreads14

Post by psi29a » 01 Mar 2017, 23:46

There is indeed something fishy, I'll create a Trusty VM and test it out.

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Can't install 0.41, no libopenthreads14

Post by psi29a » 02 Mar 2017, 12:07

OK, I just tested with a clean Trusty 14.04 and did an `apt get install openmw` after doing adding ppa:openmw/openmw and updating the repo.

Everything installed and worked without a problem.

What I think is going on however is that it is pulling libopenthreads14 from linux mint and not the ppa.
Do you want to continue? [Y/n] y
Get:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu/ trusty-updates/universe libopenthreads14 amd64 3.2.0~rc1-4ubuntu0.1 [12.8 kB]
Fetched 12.8 kB in 0s (63.8 kB/s)
This triggered the de-installation of:
Removing libopenscenegraph-3.4-130:amd64 (3.4.0+dfsg1-4+openmw1~trusty2) ...
Removing libopenthreads20 (3.4.0+dfsg1-1~trusty8) ...
libopenthreads20 (3.4.0+dfsg1-1~trusty8) doesn't exist anymore, it was part of an old package before OSG-3.4 was in debian. Sadly it wouldn't have been uninstalled and just left there causing conflicts.

To fix this, we'll need to purge a few things:

Code: Select all

sudo apt purge libopenscenegraph-3.4-130
sudo apt purge libopenthreads20
sudo apt purge libopenthreads14
sudo apt purge openmw
somethings are likely redundant, that is why we go through the list.

Once that is done, try `sudo apt install openmw` again.

That should fix it, if it does, then I know where the problem is and how to fix it. :)

jiawen
Posts: 5
Joined: 22 Feb 2016, 09:57

Re: Can't install 0.41, no libopenthreads14

Post by jiawen » 02 Mar 2017, 14:36

That worked!

I had to re-run the installation wizard and settings importer, and then for some reason, Morrowind.esm was listed below Bloodmoon.esm in my openmw.cfg file, so I had to manually put Morrowind.esm on top. However, after I did that, everything ran flawlessly.

Thank you for the help! :)

jiawen
Posts: 5
Joined: 22 Feb 2016, 09:57

Re: Can't install 0.41, no libopenthreads14

Post by jiawen » 12 Nov 2017, 06:03

Sorry to perform thread necromancy on my own thread, but this seemed like the most logical place to post...

Something in the last half-year or so broke OpenMW. I no longer have OpenMW installed, and when I purge the sources as before and then try to install the Trusty-specific PPAs, update the repositories and install openmw and openmw-launcher, I'm back to these messages:

Code: Select all

E: Package 'openmw' has no installation candidate
E: Unable to locate package openmw-launcher
Should I add a different PPA? Does something need to get tweaked in those packages?

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Can't install 0.41, no libopenthreads14

Post by psi29a » 12 Nov 2017, 08:58

Wait for the release, any day now. :) Then the PPA will be fixed.

jiawen
Posts: 5
Joined: 22 Feb 2016, 09:57

Re: Can't install 0.41, no libopenthreads14

Post by jiawen » 12 Nov 2017, 10:02

:lol: Okay, will do!

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Can't install 0.41, no libopenthreads14

Post by psi29a » 12 Nov 2017, 11:50

I've been updating packages, making things ready for the new release. There are currently no openmw packages away because new ones haven't been published yet with the new libraries.

Once the new release is there, everything should be back to normal. including the dailies.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests