Mouse cursor problem and failed exit

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
ghales
Posts: 30
Joined: 25 Jul 2014, 00:25

Mouse cursor problem and failed exit

Post by ghales » 03 Apr 2016, 23:29

OpenSuse just pushed out a 200+ package update to KDE and it broke my OpenMW.

I now have a mouse cursor when I am in first person view and I can't change which direction I am looking in (or which direction I am going). When I exit, I am left with an OpenMW item in the taskbar, but ksysguard shows no OpenMW process running. I also have no close buttons on any of my windows!? When I start OpenMW from a terminal, it returns after exit without any output at all, and the terminal window is non-responsive. The OpenMW log shows only the normal messages.

This is obviously not an OpenMW problem. It was working perfectly before the big KDE update. But that update also included patches for MyGui, OSG, and, I think, SDL and possibly other parts of OpenSuse.

Is there anyone out there who has a similar problem who can point me at the problem component?

ghales
Posts: 30
Joined: 25 Jul 2014, 00:25

Re: Mouse cursor problem and failed exit

Post by ghales » 10 Apr 2016, 21:09

After playing around a bit, I discovered that starting OpenMW with Fullscreen OFF fixes the problem. OpenMW starts, runs with working "mouse look", and terminates without corrupting the KDE desktop.

I am still leaning toward KDE being the problem (even though OpenMW is the only program I have that has issues), but I don't know where to go with this.

Locked