Linux OpenMW 0.38 suffering insane fps drops on some cells

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Posts: 4
Joined: 10 Mar 2016, 23:14

Linux OpenMW 0.38 suffering insane fps drops on some cells

Post by DJBeardsquirt » 10 Mar 2016, 23:25

The second time in 2 different saves that I've experienced this. The first time it happened in Vivec, if I went outside my screen would freeze for 30 seconds and then return. I could look around and fps seemed to have returned to normal, but if I stepped forward it would freeze again for another 30 seconds after a couple of steps.

I thought it might be a problem with my save so I started again. This time Vivec didn't hang so I thought I was all good and have been playing for about 10 hours. Today I teleported to Fort Buckmoth and experienced the same weird freezes. I tried walking there from Ald'ruhn, but as I walked towards it suddently the freezes happened again (probably as it loaded a certain cell that it doesn't like).

I'm running OpenMW 0.38.0 on Ubuntu using up to date fglrx drivers. It's the weirdest fps drop I've seen because it's somehow connected to my movement, and I can only figure that must be something to do with loading a cell.

Has anyone else experienced this?

UPDATE: I just tried running the game from the console. When it freezes I checked and it's repeatedly outputting:
Error in Objects::playAnimationGroup: Unable to find roht_mg_aldruhntelvbanner
I'm playing with the telvanni mods, and I'm wondering if that's caused a problem with the banner animation.