New OpenMW Windows development environment guide

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
ComradeKonrad
Posts: 2
Joined: 21 Feb 2015, 01:09

Re: New OpenMW Windows development environment guide

Post by ComradeKonrad » 21 Feb 2015, 03:51

Used this guide to set up development environment for the first time (Windows 7, 64 bit). Built and ran the project successfully, though I definitely had to run qtbinpatcher despite using the qt installer. Also - no mention made of the msinttypes file which was required on my friends machine despite using VS2012.

However, following your guide definitely made setting up the dev environment more approachable (my first attempt was done without and ~5 hours into it I gave up) and aside from those (minor) points, it was great - thanks for taking the time to put it together.

User avatar
sjek
Posts: 430
Joined: 22 Nov 2014, 10:51

Re: New OpenMW Windows development environment guide

Post by sjek » 22 Feb 2015, 23:04

Thanks : )

personally on xp i think i have totally messed the environment up so running it might take guite some time. Other's on 64 bit windows or other .?
"life is crazy"
"craziness has beauty which only crazies understand" some movie clip in the head.
https://wiki.openmw.org/index.php?title=Testing

User avatar
Ace (SWE)
Posts: 829
Joined: 15 Aug 2011, 14:56

Re: New OpenMW Windows development environment guide

Post by Ace (SWE) » 23 Feb 2015, 02:19

We'll see what changes OSG will result in for this guide, but hopefully I should be able to clean it up and get it linked on the wiki properly.

Also, thanks for trying it out all of you. Good that it seems to work all the way from XP to Windows 10.

ComradeKonrad
Posts: 2
Joined: 21 Feb 2015, 01:09

Re: New OpenMW Windows development environment guide

Post by ComradeKonrad » 25 Feb 2015, 23:55

First - this is only on my dev environment, downloading the OpenMW 0.35 installer for 64 bit windows does not have this problem. When I get in-game, I can't interact with world objects from the inventory menu (mousing over makes no change in the cursor / doesn't offer popup name) and I can't drag objects from my inventory to drop in the world. As this functionality exists in the "real" .exe, and as this is my first time setting up the environment, I'm not sure if I'm just doing something stupid - but I've replicated the problem across three machines now, 64 bit and 32 bit builds. Has anyone else run into this problem, or does anyone have any idea what I should look into to fix it?

I thought I'd post here first, since if I didn't do something stupid (likely) there might be a misstep in the guide.

lef42
Posts: 33
Joined: 27 Jul 2014, 16:33

Re: New OpenMW Windows development environment guide

Post by lef42 » 01 Mar 2015, 10:37

Was very easy to follow, thanks

Locked