Build OpenMW on Fedora 19

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
Nobrakal
Posts: 31
Joined: 26 Jun 2013, 16:35

Build OpenMW on Fedora 19

Post by Nobrakal » 26 Jun 2013, 16:58

Hi,

I'm a new user of OpenMW, and I want install it on my Fedora. I follow the instruction on the wiki, but it will not work...
Well, the code:

Code: Select all

-- Looking for OGRE...
-- OGRE_PREFIX_WATCH changed.
-- Found Ogre Byatis (1.8.1)
-- Found OGRE: optimized;/usr/local/lib/libOgreMain.so;debug;/usr/local/lib/libOgreMain.so
-- Looking for OGRE_Paging...
-- Found OGRE_Paging: optimized;/usr/local/lib/libOgrePaging.so;debug;/usr/local/lib/libOgrePaging.so
-- Looking for OGRE_Terrain...
-- Found OGRE_Terrain: optimized;/usr/local/lib/libOgreTerrain.so;debug;/usr/local/lib/libOgreTerrain.so
-- Looking for OGRE_Property...
-- Found OGRE_Property: optimized;/usr/local/lib/libOgreProperty.so;debug;/usr/local/lib/libOgreProperty.so
-- Looking for OGRE_RTShaderSystem...
-- Found OGRE_RTShaderSystem: optimized;/usr/local/lib/libOgreRTShaderSystem.so;debug;/usr/local/lib/libOgreRTShaderSystem.so
--  libraries : MyGUIEngine;MyGUI.OgrePlatform from /usr/lib
--  includes : /usr/include/MYGUI
-- Boost version: 1.53.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   program_options
--   thread
--   date_time
--   wave
-- Found Qt4: /usr/bin/qmake-qt4 (found version "4.8.4") 
-- Found Qt4: /usr/bin/qmake-qt4 (found version "4.8.4") 
-- Found Qt4: /usr/bin/qmake-qt4 (found version "4.8.4") 
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
SDL2MAIN_LIBRARY
    linked by target "openmw" in directory /home/Nobrakal/openmw/apps/openmw

-- Configuring incomplete, errors occurred!
SDL2 is installed (and devel), and I run cmake in root.

Thank you for your help!

Alexandre

wheybags
Posts: 207
Joined: 21 Dec 2012, 19:41

Re: Build OpenMW on Fedora 19

Post by wheybags » 26 Jun 2013, 23:04

You ran cmake as root? O.o

User avatar
psi29a
Posts: 4807
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Build OpenMW on Fedora 19

Post by psi29a » 27 Jun 2013, 08:39

@Nobrakal: does 'sdl2-config --libs' command work?

Nobrakal
Posts: 31
Joined: 26 Jun 2013, 16:35

Re: Build OpenMW on Fedora 19

Post by Nobrakal » 27 Jun 2013, 12:07

Hi,

Yes the command 'sdl2-config --libs' works and return

Code: Select all

-lSDL2 -lpthread
But cmake doesn't work

Thank's for your response,

Alexandre

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Build OpenMW on Fedora 19

Post by scrawl » 27 Jun 2013, 14:21

SDL2main is only required for windows I think (though for me it worked on windows even without it, but it didn't for Ace so he added it).
The cmake script should probably be changed to only add SDL2MAIN_LIBRARY if (!unix).

Nobrakal
Posts: 31
Joined: 26 Jun 2013, 16:35

Re: Build OpenMW on Fedora 19

Post by Nobrakal » 27 Jun 2013, 15:30

Hi,

Well, I don't know cmake...
Can you help me to add this line?

Thank you very much,

Alexandre

User avatar
scrawl
Posts: 2152
Joined: 18 Feb 2012, 11:51

Re: Build OpenMW on Fedora 19

Post by scrawl » 27 Jun 2013, 16:33


Nobrakal
Posts: 31
Joined: 26 Jun 2013, 16:35

Re: Build OpenMW on Fedora 19

Post by Nobrakal » 27 Jun 2013, 20:15

It's works for me!

Thank's very much!

And I have another question...
How I can save?

Thanks for your quickly help

Alexandre

User avatar
psi29a
Posts: 4807
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: Build OpenMW on Fedora 19

Post by psi29a » 28 Jun 2013, 08:05

Save and load are not implemented yet.

Nobrakal
Posts: 31
Joined: 26 Jun 2013, 16:35

Re: Build OpenMW on Fedora 19

Post by Nobrakal » 28 Jun 2013, 09:33

Ok, Thank you for your help

Alexandre

Locked