Dead keys do not work

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
User avatar
Okulo
Posts: 672
Joined: 05 Feb 2012, 16:11

Dead keys do not work

Post by Okulo » 28 May 2013, 23:01

In many keyboard layouts, including the US-International layout, one creates quotation marks by pressing shift-' and then pressing space. As of version 0.24.0-RC1, this still does not work in the console - it will just space without the quotes. This is quite problematic if you need to use quotation marks for anything. Any kind of dead key will just not work, be it ', ", `, ~ or anything else.

Please ensure compatibility with US-International and other keyboard layouts.

silentthief
Posts: 424
Joined: 18 Apr 2013, 01:20
Location: Currently traversing the Ascadian Isles

Re: Dead keys do not work

Post by silentthief » 28 May 2013, 23:14

yeah, don't know if this is build-specific (I'm on ubuntu 12.4) but you can remap the controls for some keys in-game using options. this was the only way I could open the console

ST
"You like to dance close to the fire, don't you?."

User avatar
Okulo
Posts: 672
Joined: 05 Feb 2012, 16:11

Re: Dead keys do not work

Post by Okulo » 29 May 2013, 04:04

Opening the console is F2 by default though.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Dead keys do not work

Post by Zini » 29 May 2013, 09:25


silentthief
Posts: 424
Joined: 18 Apr 2013, 01:20
Location: Currently traversing the Ascadian Isles

Re: Dead keys do not work

Post by silentthief » 29 May 2013, 18:43

Okulo wrote:Opening the console is F2 by default though.
yeah, I know. I was just letting OP know how I dealt with it. It might help if original post included operating system.
I have an HP presario laptop came preloaded with win7 and a ton of bloatware, put linux on it instead (ubuntu 12.4) and not sure if it has problem with F2 on all programs or just this, will look into it. The switch to linux did affect some things such as not being able to use prebuilt internal wifi, but I've also heard that those laptops had issues with the internal wifi and other stuff breaking after 4 months or so.

ST
"You like to dance close to the fire, don't you?."

User avatar
Okulo
Posts: 672
Joined: 05 Feb 2012, 16:11

Re: Dead keys do not work

Post by Okulo » 31 May 2013, 19:46

My main OS is Windows 7.

Dealing with the issue by rebinding your console key is different, though. In its current state I cannot go to, say, the Caldera Mages Guild because I'd need to type coc "Caldera, Guild of Mages". With the dead keys issue you cannot type the ", and you cannot rebind that.

Thanks for putting it on the bugtracker.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: Dead keys do not work

Post by Zini » 31 May 2013, 19:57

Its been ages since I have touched Windows (except for playing games on it). But can't you input characters by holding down the alt key and entering the ASCII code of the character on the numeric keypad? (that would be 34 for ").

Tarius
Posts: 574
Joined: 24 Oct 2011, 19:29

Re: Dead keys do not work

Post by Tarius » 31 May 2013, 20:56

Zini wrote:Its been ages since I have touched Windows (except for playing games on it). But can't you input characters by holding down the alt key and entering the ASCII code of the character on the numeric keypad? (that would be 34 for ").
Yes you can.

¥ ¿ ƒ
And I just did some random characters like that.
I am a bigger fan of tons of control rather than taking the "user-friendly" approach.
-Okulo

User avatar
Okulo
Posts: 672
Joined: 05 Feb 2012, 16:11

Re: Dead keys do not work

Post by Okulo » 05 Jun 2013, 13:50

That's a nice workaround until OpenMW understands US-International keyboards and other dead key enabled layouts at least.

Locked