0.23.0 Bugs

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
RabidSquirrel
Posts: 37
Joined: 18 Dec 2012, 07:52

0.23.0 Bugs

Post by RabidSquirrel » 29 Apr 2013, 00:17

Jump animation not working for me.

When swimming, if I'm on the surface and I try to swim up the animation is buggy, like it doesn't know whether to swim or walk.

Look at the ground, then move the mouse to the side really slowly. You can see that your character starts moving, like circle-strafing a point a couple feet in front of you. (This is true regardless of where you're looking.)

PS: It would be awesome if the next version would remember the size/locations of my menu windows.

User avatar
sirherrbatka
Posts: 2157
Joined: 07 Aug 2011, 17:21

Re: 0.23.0 Bugs

Post by sirherrbatka » 29 Apr 2013, 15:39

0.23.0 linux 32 bit binary is unplayabe here. It takes minute to fill up whole 2 gigabytes of RAM and then it swaps… and i get a slideshow.

User avatar
raevol
Posts: 3067
Joined: 07 Aug 2011, 01:12
Location: Caldera

Re: 0.23.0 Bugs

Post by raevol » 29 Apr 2013, 17:38

sirherrbatka wrote:0.23.0 linux 32 bit binary is unplayabe here. It takes minute to fill up whole 2 gigabytes of RAM and then it swaps… and i get a slideshow.
Well that ain't good... I can confirm that the .deb from the PPA is fine?

User avatar
sirherrbatka
Posts: 2157
Joined: 07 Aug 2011, 17:21

Re: 0.23.0 Bugs

Post by sirherrbatka » 29 Apr 2013, 17:48

can you check binary 32 tar.gz package?

User avatar
nnayo
Posts: 72
Joined: 25 Feb 2013, 15:05
Location: Cannes, France

Re: 0.23.0 Bugs

Post by nnayo » 29 Apr 2013, 17:57

same here under Ubuntu.
with my quite old PC and its 1Go, the swap triggers in less than 10 minutes...
so sad but true

User avatar
psi29a
Posts: 4807
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: 0.23.0 Bugs

Post by psi29a » 29 Apr 2013, 22:39

Is this the tgz that is causing problem or the deb or both? We need concrete information like:
type (tgz/deb)
version (32/64)
distro (debian/ubuntu/redhat)
release (precise,wheezy,quantal, raring)

From what I gather, it is only tgz that is problem and that debs are OK?

User avatar
nnayo
Posts: 72
Joined: 25 Feb 2013, 15:05
Location: Cannes, France

Re: 0.23.0 Bugs

Post by nnayo » 30 Apr 2013, 06:35

it happens for me with:
deb / 32-bit / ubuntu / quantal

User avatar
psi29a
Posts: 4807
Joined: 29 Sep 2011, 10:13
Location: Belgium
Gitlab profile: https://gitlab.com/psi29a/
Contact:

Re: 0.23.0 Bugs

Post by psi29a » 30 Apr 2013, 07:57

Do we still have problems with the 32bit build on Windows too?

Does this happen on 64bit debs/tgz/windows?

Can we confirm that this does not happen on 0.22.0 32-bit builds (linux/windows/osx)?

User avatar
sirherrbatka
Posts: 2157
Joined: 07 Aug 2011, 17:21

Re: 0.23.0 Bugs

Post by sirherrbatka » 30 Apr 2013, 08:35

32 bit 0.22.0 tgz binary works fine on the same system.

EDIT
According to brotherbrick polite request
post it fucker
i post my system. It is pclinuxos 32 bits.

User avatar
Zini
Posts: 5537
Joined: 06 Aug 2011, 15:16

Re: 0.23.0 Bugs

Post by Zini » 01 May 2013, 18:03

I guess we need to figure out first if that is a packaging problem or if OpenMW has stopped working on 32 bit Linux in general. Its Linux only, right? 32 bit Windows still working?

Do we still have any developers who work on a 32 bit Linux system? If yes, does OpenMW work there? And if it doesn't, any chance we could get it git bisect'ed?

Locked