Weird horizontal line won't go away

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
PyGuy
Posts: 1
Joined: 07 Oct 2012, 00:14

Weird horizontal line won't go away

Post by PyGuy » 07 Oct 2012, 02:19

Hey guys. I admire the great progress you guys are making with this project and I am willing to support in any way a person that doesn't know how to code can do. However, when I launched the game, some weird line is following my view and I can't seem to make it disappear. This only seems to happen when I'm in my Linux partition, while on Windows everything looks fine.

Here's exactly what I see:
Screenshot 1: http://i.imgur.com/eh9rl.jpg
Screenshot 2: http://i.imgur.com/uQTPE.jpg

I'll start with my specs:
OS: Ubuntu 12.04.1 64-bit + Windows 7 Home Premium 64-bit
CPU: Intel Core i5-2400
GPU: Nvidia GeForce GTX 560
RAM: 8GB DDR3 1333 Mhz
Native Resolution: 1600x900 59Hz

Steps I took on Windows:
Installed OpenMW from the exe file.
Configured the launcher to detect my Morrowind installation.
Set the resolution to my native full screen resolution and started playing.
Everything works fine.

Steps I took on Linux:
Extracted the tar.gz file to my Home directory and renamed it "OpenMW"
Opened OpenMW.cfg and changed it to look like this

Code: Select all

data= /home/[my_username]/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files
resources= /home/[my_username]/OpenMW/resources
Started the game and was greeted by an annoying line across the screen.

Resolutions I've tried:
1600x900 full screen on both Windows and Linux
1360x768 windowed on Linux

And last, but certainly not least, everything that displayed on the terminal from when I launched it from the terminal to when I clicked "Exit" on the in-game menu:

Code: Select all

[email protected]ew-desktop:~/OpenMW$ sh openmw
Loading config file: /home/andrew/.config/openmw/openmw.cfg... done.
Loading config file: ./openmw.cfg... done.
Using default (English) font encoding.
No master file given. Assuming Morrowind.esm
Adding /home/andrew/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files/Bloodmoon.bsa
Adding /home/andrew/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files/Morrowind.bsa
Adding /home/andrew/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files/Tribunal.bsa
Data dir /home/andrew/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files
Loading ESM /home/andrew/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Morrowind/Data Files/Morrowind.esm
Sound output: OpenAL
Sound decoder: mpg123,sndfile
Enumerated output devices:
  Built-in Audio Analog Stereo
  GF110 High Definition Audio Controller Digital Stereo (HDMI)
Opened "Built-in Audio Analog Stereo"
Changing to interior
loading cell Beshara
cellName:Beshara

Press Q/ESC or close window to exit.
Playing Music/Explore/mx_explore_2.mp3
Quitting peacefully.

User avatar
werdanith
Posts: 295
Joined: 26 Aug 2011, 16:18

Re: Weird horizontal line won't go away

Post by werdanith » 16 Oct 2012, 20:05

Yeah, the tar package was packaged with an older Ogre version, and apparently everyone missed it until now.
Since you are on Ubuntu I suggest either installing through our ppa or if you want to see the current progress you can compile from source, which is as easy as it can get on Ubuntu. See Setting up a dev environment

Locked