Three weird boxes and transparency issues

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
User avatar
Greendogo
Posts: 1420
Joined: 26 Aug 2011, 02:04

Three weird boxes and transparency issues

Post by Greendogo » 26 Sep 2012, 02:02

I'm not really sure what's going on here:
http://imgur.com/t59Lq

Running Ace's most recent RC.

User avatar
ap0
Posts: 290
Joined: 11 Aug 2011, 18:47
Contact:

Re: Three weird boxes and transparency issues

Post by ap0 » 26 Sep 2012, 11:57

Boxes are the debug overlay. You can disable it in the option's menu.
The world's map is not implemented yet, this is why our window is empty.

User avatar
Greendogo
Posts: 1420
Joined: 26 Aug 2011, 02:04

Re: Three weird boxes and transparency issues

Post by Greendogo » 26 Sep 2012, 12:34

Sorry, I didn't explain myself very well. I know the boxes were something I turned on, but they didn't turn off when I turned off all the shaders and everything. And the map issue isn't a matter of the world map not being done yet, it was transparent regardless of being set to "local" or "world" map, without my having to touch the transparency slider.

The three white "debug" boxes stayed on after:
Going from:
  • shaders -> on
    debug overlay -> on
To:
  • shaders -> off
    debug overlay -> on
And even after doing this:
  • shaders -> off
    debug overlay -> off (I could still manipulate the option, even though the whole menu should have been disabled)
But this actually turned it off
  • shaders -> on
    debug overlay -> off
Basically, it stayed on after the parent option for shaders were turned off, which cut control of the function off (even though it was still toggleable), which was only reasserted after the shader menu was back on again.

Anyway, I think both of these issues are problems with menu logic; it should be simple to fix them both, except I can't reliably reproduce the transparency issue. It seems to happen at random times.

User avatar
Greendogo
Posts: 1420
Joined: 26 Aug 2011, 02:04

Re: Three weird boxes and transparency issues

Post by Greendogo » 26 Sep 2012, 12:40

I managed to find a way to reproduce the transparency issue (which manifests itself in all kinds of ways). This may only affect Windows users.

First, open the game. Then Alt + Tab out of the game, and then back in. Press ESC. The ESC menu should be invisible.

Locked