[Arch Linux] locale.conf LANG=en_US.UTF-8

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Locked
User avatar
bwrsandman
Posts: 45
Joined: 25 Sep 2011, 05:30
Location: Montreal
Contact:

[Arch Linux] locale.conf LANG=en_US.UTF-8

Post by bwrsandman » 08 Sep 2012, 18:21

Recently, Arch users have been urged to move their settings out of /etc/rc.conf and into several files.
One such file is /etc/locale.conf the example they provide is to set LANG="en_US.UTF-8".
What I find is that particular setting causes issues with openmw.

Here are my locale settings:

Code: Select all

# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
These settings don't run well with openmw:

Code: Select all

# openmw

ERROR: locale::facet::_S_create_c_locale name not valid

Code: Select all

# omwlauncher 
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Aborted
The way to avoid this is to set LANG=C in either one of the following ways:

Code: Select all

# LANG=C openmw
# export LANG=C && openmw
or to have "LANG=C" in your /etc/locale.conf file.

This seems to be a boost related bug. My version is boost 1.50.0-2

Locked