[SOLVED] Unable to compilation in Manjaro/Arch

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
User avatar
AnyOldName3
Posts: 2023
Joined: 26 Nov 2015, 03:25

Re: [SOLVED] Unable to compilation in Manjaro/Arch

Post by AnyOldName3 » 09 Jan 2021, 18:07

You'll only see a performance boost from multithreaded bullet if you tell OpenMW to use at least two asynchronous physics threads. As we've said, though, you'll only be able to build OpenMW using Bullet compiled with -DUSE_DOUBLE_PRECISION=ON from now on.
AnyOldName3, Master of Shadows

unelsson
Posts: 216
Joined: 17 Mar 2018, 14:57

Re: [SOLVED] Unable to compilation in Manjaro/Arch

Post by unelsson » 13 Jan 2021, 14:36

Naugrim wrote:
05 Jan 2021, 22:21
unelsson wrote:
04 Jan 2021, 00:39
I'm using Manjaro, and haven't encountered problems using bullet 3.05-1.
I am curious, I tried again with 3.05-1, 3.05-2 and 3.07-1 and I get the error.
I updated the system, and got 3.07-1 and OpenMW stopped building. Replaced that with bullet-multithreaded 3.08-1 from AUR and it works again. I don't know what was going on previously.

Post Reply