Compiling on Windows (VS2017)

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
kleril
Posts: 2
Joined: 29 Nov 2019, 08:28

Compiling on Windows (VS2017)

Post by kleril » 29 Nov 2019, 08:42

Been trying to get a working development environment so I can start contributing to the project; got through this guide after a long series of trying to get the right Windows SDKs. The build script looks to have run without issue, but now I'm stuck on trying to compile. Looks to be this issue where openGL headers are getting built before the windows header. I'm assuming the project code itself is fine, as devs must be able to compile without running into this.

I'm at a loss as to what could be causing this, perhaps something's gone wrong with the make files? Please let me know what information I can provide to help debug this.

User avatar
AnyOldName3
Posts: 1591
Joined: 26 Nov 2015, 03:25

Re: Compiling on Windows (VS2017)

Post by AnyOldName3 » 29 Nov 2019, 21:43

I've had this working on pretty much fresh Windows installs before, so I'd be inclined to assume something's installed incorrectly or you've installed the wrong version of something (or multiple versions and a dodgy version is taking precedence).

The VS 2017 used to sometimes do dumb stuff and need reinstalling a few times before everything would work, so that's a possible avenue to pursue. I think those issues have mostly been solved, though, so maybe not.

I've had the Windows header/OpenGL header issue happen in the past with other projects due to compiler definitions being wrong, too.

If you're sure everything's installed properly (you've asked the VS Installer to repair the installation of everything and you've definitely got it showing that you've got Desktop Development for C++ and a Windows SDK) and that a clean rebuild (starting from scratch instead of just cleaning from within CMake or VS) doesn't fix it, you should upload your error list here (potentially via pastebin).
AnyOldName3, Master of Shadows

kleril
Posts: 2
Joined: 29 Nov 2019, 08:28

[Solved] Compiling on Windows (VS2017)

Post by kleril » 30 Nov 2019, 06:22

A full reinstall of the openMW project seems to have fixed it. Not sure how or why, but the .sln file was generated in the project's root directory rather than MSVC2017_64 the first time.

Post Reply