Need to rerun Wizard every time due to changing file location

Support for running, installing or compiling OpenMW

Before you submit a bug report for the first time, please read: Bug reporting guidelines
Post Reply
oxensoxen
Posts: 2
Joined: 16 Jun 2019, 14:28

Need to rerun Wizard every time due to changing file location

Post by oxensoxen » 16 Jun 2019, 14:38

I just installed OpenMW and Morrowind (via steam) last night and am having a minor issue (using Linux Mint 19.1).

The Morrowind files are only visible after starting Steam, and each time I start Steam, the files are in a different location, such as:
/proc/5022/cwd/steamapps/common/Morrowind/Data Files

So every time I start the game the MW file location is different because the proc folder changes each time so OpenMW can't find the MW files. I need to locate the current proc folder with them via the Wizard each time I start the game.

Is there a way to avoid this? Or is it just what happens when you install MW via Steam?

Chris
Posts: 1558
Joined: 04 Sep 2011, 08:33

Re: Need to rerun Wizard every time due to changing file location

Post by Chris » 16 Jun 2019, 23:24

Sounds like something is pretty messed up with Steam. On Linux, Steam should install files into ~/.steam/steam/SteamApps/common/Morrowind/Data Files, rather than the process's current working directory. Are you overriding Steam's config/data path? How did you install and how are you running Steam?

oxensoxen
Posts: 2
Joined: 16 Jun 2019, 14:28

Re: Need to rerun Wizard every time due to changing file location

Post by oxensoxen » 17 Jun 2019, 12:42

From what I can recall (this is my first try at using Steam as well), I went to steam and hit the Install Steam button. But, yes, ~/.steam/steam/steamapps folder doesn't have anything in it regarding morrowind.

Once I had steam installed, it wouldn't let me install MW, so I looked up downloading Windows games with Linux STeam and fuond this: https://itsfoss.com/steam-play/ so I went into Steam Settings, turned on the Steam Beta to get Steam Stream and selected "Enable Steam Play for all other titles" . I assume that maybe this is part of the problem, but I was unable to get it to install MW at all before I did this.

Post Reply