fail to load esm

Involved development of the OpenMW construction set.
Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

fail to load esm

Post by Tinker » 27 Oct 2014, 12:12

On trying to open Necessities of Morrowind to correct a few script errors with OpenCS I get the message loading failed ESM error Expected sub record FRMR but got PGRD. NoM seems to work OK in OpenMW, apart from warnings in the log.

I think the message should read ESP error but also I have no idea what the message means or how to get around the failure to open to correct the errors which seem to be mainly startcsript stopscript errors where the script name is different.
Arch Linux - rolling release, always up to date, often partly broken.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: fail to load esm

Post by Zini » 27 Oct 2014, 12:40

The error indicates that OpenCS tries to finish reading a cell record but instead finds the beginning of a new pathgrid record. While there are a few variations between OpenCS and OpenMW they mostly share the loading code. Having loading fail in one but not the other is rather unexpected.

Can we see the the OpenWM log?

Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

Re: fail to load esm

Post by Tinker » 27 Oct 2014, 13:26

Apart from the line

Code: Select all

Loading content file NoM 3.0.esp
the only mention of Nom in the OpernMW log is a couple of warnings like

Code: Select all

warning line 95, column 14 (imp_thirst)
    Names for script NOM_thirst do not match
and one actual error

Code: Select all

error line 104, column 11 (,)
    Unexpected special token
compiling failed: NoM_satchel_open
There are also a few references to

Code: Select all

error during rendering: Object '' not found (const)
but it is not clear what they refer to.

I could add the whole log if you need it but it is several thousand lines long from an extended session yesterday, I could start up a shorter session that will show NoM loads.
Arch Linux - rolling release, always up to date, often partly broken.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: fail to load esm

Post by Zini » 27 Oct 2014, 13:42

The first one (warning) is harmless.

For the second one I would have to see the script, but it is probably defective.

The 3rd one however is very serious. It seems that this mod is actually not loading correctly into OpenMW either. I suggest you file on issue on our bug tracker (and don't forget to mention the OpenCS loading issue in the description since these are probably related).

Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

Re: fail to load esm

Post by Tinker » 27 Oct 2014, 14:33

I will do a bit more testing first, I was running several mods to test compatibility and there is no indication of which one caused the third message, the other two were definitely NoM. I am in contact with Taddeus who wrote it and he is correcting the warnings and I have asked for a copy of the faulty script, unless he spots the error and fixes it.
Arch Linux - rolling release, always up to date, often partly broken.

Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

Re: fail to load esm

Post by Tinker » 30 Oct 2014, 09:56

Just to confirm the object rendering error has nothing to do with NoM, it is caused by one of abot's mods, they are not working as functions he calls are not yet implemented, GetPCView is one that is used a lot.
Arch Linux - rolling release, always up to date, often partly broken.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: fail to load esm

Post by Zini » 30 Oct 2014, 10:15

Two bugs instead of one then. :(

Can you please file both on our tracker?

Also, getPCView? I am not aware that such a function exists. Its not on our list and I can't find any documentation about it.

Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

Re: fail to load esm

Post by Tinker » 30 Oct 2014, 12:03

Sorry about that I was trying to remember what the error was, I loaded it back in to check and the errors are with PCGet3rdPerson and HitAttemptOnMe.

The Nom error is already on the tracker I will add this one today.
Arch Linux - rolling release, always up to date, often partly broken.

User avatar
Zini
Posts: 5134
Joined: 06 Aug 2011, 15:16

Re: fail to load esm

Post by Zini » 20 Nov 2014, 12:52

Can we have another test regarding the NOM error please? In OpenMW what happens when you go near the cell -9, 8? Anything suspicious on the console?

Tinker
Posts: 229
Joined: 06 Mar 2013, 17:35

Re: fail to load esm

Post by Tinker » 22 Nov 2014, 12:16

Apart from a couple of nif errors and the NoM script names warning the only error message is

Code: Select all

warning line 37, column 5 (endif)
    endif without matching if/elseif
which does seem to pop up a lot with no idea of which script causes it.

I tried coe to -9,8 and also to a nearby cell then walking to -9,8.
Arch Linux - rolling release, always up to date, often partly broken.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest