Visual Studio 2015: Access Denied When debugging

Everything about development and the OpenMW source code.
Post Reply
hamod9041
Posts: 1
Joined: 02 Aug 2018, 11:17

Visual Studio 2015: Access Denied When debugging

Post by hamod9041 » 02 Aug 2018, 11:22

I recently setup my development environment for openmw. Everything seems to be OK, but when I try to debug the program it reads:

Unable to start Program
'D:\openmw-dev\openmw\msvc2015_64\x64\debug\ALL_BUILD'
Access is Denied

I tried running it as an admin but it didn't work. Does anyone know of the solution?

mattwla
Posts: 59
Joined: 17 Jul 2017, 14:45

Re: Visual Studio 2015: Access Denied When debugging

Post by mattwla » 02 Aug 2018, 17:07

So, my procedure for debugging is to launch openmw.exe than in visual studio use the "Attach to process" feature and choose openmw.exe

Works every time!

User avatar
AnyOldName3
Posts: 1140
Joined: 26 Nov 2015, 03:25

Re: Visual Studio 2015: Access Denied When debugging

Post by AnyOldName3 » 02 Aug 2018, 17:42

Right-click on the project you actually want to debug from Solution Explorer and choose 'Set as startup project'. Right now, you're trying to debug the ALL_BUILD project, which is a meta-project used to build all projects at once, and doesn't itself have an executable.
AnyOldName3, Master of Shadows

sarahvag
Posts: 1
Joined: 13 Nov 2018, 12:23
Github profile: https://github.community/t5/user/viewpr ... /user-id/8

Re: Visual Studio 2015: Access Denied When debugging

Post by sarahvag » 13 Nov 2018, 13:25

Try to run as administrator it will work.

User avatar
AnyOldName3
Posts: 1140
Joined: 26 Nov 2015, 03:25

Re: Visual Studio 2015: Access Denied When debugging

Post by AnyOldName3 » 13 Nov 2018, 14:00

That won't help. Not every access denied issue can be solved with more access. The problem here was that there's nothing to access in the first place.
AnyOldName3, Master of Shadows

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests