Shadows

Everything about development and the OpenMW source code.
magamo
Posts: 72
Joined: 28 May 2016, 17:28

Re: Shadows

Post by magamo » 15 Nov 2017, 12:34

Also, recent versions of the nvidia binary drivers for Linux handle Optimus somewhat well enough on their own. You just switch GPUs using the nvidia-settings tool, and cycle your login. It's not as seamless and elegant as bumblebee or primusrun, but there's nothing additional to install, and configuring it is a lot easier than it used to be.

User avatar
AnyOldName3
Posts: 563
Joined: 26 Nov 2015, 03:25

Re: Shadows

Post by AnyOldName3 » 16 Nov 2017, 01:17

So far, making a bootable USB drive with persistence has been a pretty massive ordeal spanning 27 hours, three computers, and either six or seven fresh starts. I'm currently staring at a BusyBox prompt. I'm starting to think there's something wrong with the drive I'm using or some other weird and impossible issue, because every other time I've tried this task in my life, it's taken about six mouse clicks and then has worked perfectly from then on.

User avatar
drummyfish
Posts: 82
Joined: 22 Oct 2017, 10:13
Github profile: https://github.com/drummyfish
Contact:

Re: Shadows

Post by drummyfish » 16 Nov 2017, 14:59

I wanted to test the shadows but I'm only seeing a cyan rectangle in the bottom left of the screen :) Is there anything I have to do to enable this, or is it just in untestable state now?

User avatar
AnyOldName3
Posts: 563
Joined: 26 Nov 2015, 03:25

Re: Shadows

Post by AnyOldName3 » 16 Nov 2017, 15:23

You need shaders on in settings.cfg and it should work. The not-quite-cyan (I think it's best described as teal, but that's not important) box is supposed to display a representation of the shadow maps so I can see what is and isn't working, both in my own testing and when looking at other people's screenshots, so while all you need to do is toggle a single boolean in components/sceneutil/shadow.hpp to disable it, screenshots of errors without it aren't much help to me.

There are a couple of people who've contacted me with errors I can't reproduce, and from them I need to know some basic details about their computer and OSG version.

User avatar
drummyfish
Posts: 82
Joined: 22 Oct 2017, 10:13
Github profile: https://github.com/drummyfish
Contact:

Re: Shadows

Post by drummyfish » 16 Nov 2017, 16:06

I'm not very good with colors! Anyway thank you, it works now :) You probably know this already, but changing view distance messes the shadows up sometimes.

CinuMod32
Posts: 3
Joined: 16 Nov 2017, 19:40

Re: Shadows

Post by CinuMod32 » 16 Nov 2017, 19:43

Built for x64 vs 2017 release on windows 10 with the latest commit, got this error:
---------------------------
openmw-launcher.exe - Entry Point Not Found
---------------------------
The procedure entry point ?wheelEvent@QListView@@MEAAXPEAVQWheelEvent@@@Z could not be located in the dynamic link library C:\GitHub\openmw\MSVC2017_64\Release\openmw-launcher.exe.

Please help, thanks!

User avatar
AnyOldName3
Posts: 563
Joined: 26 Nov 2015, 03:25

Re: Shadows

Post by AnyOldName3 » 16 Nov 2017, 20:33

How are you doing that build? Is it being set up by Ace's CI script? If not, then the issue is because of something you've done.

Either way, I'd be very surprised if you don't have the same issue with the master branch (as I've not touched the launcher), and in that case, you're better off asking for help in a different thread.

CinuMod32
Posts: 3
Joined: 16 Nov 2017, 19:40

Re: Shadows

Post by CinuMod32 » 16 Nov 2017, 20:44

Yes I am using the CI script. I might try to build it for VS2015, and see if it works.

EDIT: Still doesn't work, taking this issue elsewhere.

User avatar
AnyOldName3
Posts: 563
Joined: 26 Nov 2015, 03:25

Re: Shadows

Post by AnyOldName3 » 18 Nov 2017, 22:02

I just had a go with my branch on an Ubuntu laptop that only has integrated graphics, and shadows seemed to work exactly as well there as they do under Windows (although a lot slower). Interestingly, though that seemed to pull a build of OSG reporting its version as 3.4.1 from the PPA, whereas my VM, which does have some issues (which might just be because it's a VM), reports the OSG version as 3.4.0, despite apt telling me everything's up to date.

User avatar
psi29a
Posts: 3448
Joined: 29 Sep 2011, 10:13
Github profile: https://github.com/psi29a/
Contact:

Re: Shadows

Post by psi29a » 19 Nov 2017, 18:57

Yes, I've updated the PPA to use the latest Bullet and OSG revisions.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests