Connection lost repeat error with "Nil" in it, please help

Everything having to do with OpenMW's TES3MP branch.
Post Reply
Syrus11
Posts: 1
Joined: 26 Apr 2020, 11:50

Connection lost repeat error with "Nil" in it, please help

Post by Syrus11 » 26 Apr 2020, 12:04

Hi folks,

my buddy and I play on my multiplayer server, it's been great fun, but recently we've been running into trouble.

Here's our mod list for Tesmp

{"Morrowind.esm": ["0x7B6AF5B9", "0x34282D67"]},
{"Tribunal.esm": ["0xF481F334", "0x211329EF"]},
{"Bloodmoon.esm": ["0x43DD2132", "0x9EB62F26"]},
{"Encumberance increaser StrX7.5.esp": []},
{"RunFaster-Faster.ESP": []},
{"Morrowind Rebirth - Birthsigns [Addon].ESP": []},
{"Morrowind Rebirth - Game Settings [Addon].ESP": []},
{"Morrowind Rebirth - Mercenaries [Addon].ESP": []},
{"Morrowind Rebirth - Races [Addon].esp": []},
{"Morrowind Rebirth - Skills [Addon].ESP": []},
{"Morrowind Rebirth - Tools [Addon].ESP": []},
{"Morrowind Rebirth [Main].ESP": []},
{"Oblivionized Magicka Regeneration.esp": []}
{"adamantiumarmor.esp": []},
{"EBQ_Artifact.esp": []},
{"entertainers.esp": []},
{"Siege at Firemoth [For Rebirth].esp": []},
{"Rich Creeper.ESP": []}
{"Welcome to the Arena! v6.6.esp": []}
]

We recently uninstalled "welcome to the arena..." when we did so we started noticing crash messages such as
Failed to load 'meshes/f/furn_de_table_07.nif': NIFFile Error: Unsupported NIF version: ., using marker_error.nif instead
Warning: texture layer 2 is in use but empty in meshes/tm/dwemer_soultrap.nif
Unhandled controller NiPathController on node 91 in meshes/e/magic_hit_rest.nif
We kept getting a LOT mesh errors such as the one directly above

After we kept getting these error, I reinstalled the Arena mod onto the server. After reinstalling we could play the game for longer

I'm fairly certain the Arena mod+ Rebirth is what broke the game. I'm wondering if the easiest solution is just to backup the characters and possibly quest data and do a fresh installation of Tes3mp without the Arena mod. Please advise the best course of action and also instruction as how to back up quest data :). I appreciate your time and attention


openmw.log
Loading config file: C:\Program Files\OpenMW 0.46.0/openmw.cfg
Loading config file: C:\Users\Daniel\Documents\My Games\OpenMW/openmw.cfg
OpenMW version 0.46.0
Revision: 8779d261ba
Using default (English) font encoding.
OSG version: 3.4.1
SDL version: 2.0.7
Loading settings file: C:\Program Files\OpenMW 0.46.0/settings-default.cfg
Loading settings file: C:\Users\Daniel\Documents\My Games\OpenMW/settings.cfg
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Morrowind.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Tribunal.bsa
Adding BSA archive C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files\Bloodmoon.bsa
Adding data directory resources\vfs
Adding data directory C:\Program Files (x86)\Steam\steamapps\common\Morrowind\Data Files
Adding data directory C:\Users\Daniel\Documents\My Games\OpenMW/data
Loading keybindings file: C:\Users\Daniel\Documents\My Games\OpenMW/input_v3.xml
Initializing OpenAL...
Opened "OpenAL Soft on Headset Earphone (HyperX Virtual Surround Sound)"
ALC Version: 1.1
ALC Extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFTX_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_pause_device
Vendor: OpenAL Community
Renderer: OpenAL Soft
Version: 1.1 ALSOFT 1.17.2
Extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_block_alignment AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length
HRTF disabled
Allocated 256 sound sources
Low-pass filter supported
EAX Reverb supported
Enumerated output devices:
OpenAL Soft on Headset Earphone (HyperX Virtual Surround Sound) OpenAL Soft on Speakers / Headphones (Realtek Audio)
Loading content file Morrowind.esm
Loading content file Tribunal.esm
Loading content file Bloodmoon.esm
Loading content file Encumberance increaser StrX7.5.esp
Loading content file RunFaster-Faster.ESP
Loading content file Morrowind Rebirth - Birthsigns [Addon].ESP
Loading content file Morrowind Rebirth - Game Settings [Addon].ESP
Loading content file Morrowind Rebirth - Mercenaries [Addon].ESP
Loading content file Morrowind Rebirth - Races [Addon].esp
Loading content file Morrowind Rebirth - Skills [Addon].ESP
Loading content file Morrowind Rebirth - Tools [Addon].ESP
Loading content file Morrowind Rebirth [Main].ESP
Loading content file Oblivionized Magicka Regeneration.esp
Loading content file adamantiumarmor.esp
Loading content file EBQ_Artifact.esp
Loading content file entertainers.esp
Loading content file Siege at Firemoth [For Rebirth].esp
Loading content file Rich Creeper.ESP
Playing music/special/morrowind title.mp3
Quitting peacefully.
Attachments
tes3mp-client-2020-04-26-09_56_23 (2).log
(6.54 KiB) Downloaded 14 times
tes3mp-server-2020-04-26-03_20_20.log
(543.1 KiB) Downloaded 14 times
tes3mp-client-2020-04-26-03_20_43.log
(102.25 KiB) Downloaded 14 times
tes3mp-server-2020-04-26-03_40_34.log
(473.85 KiB) Downloaded 14 times
tes3mp-client-2020-04-26-03_40_40.log
(80.55 KiB) Downloaded 13 times

davidcernat
Posts: 225
Joined: 19 Jul 2016, 01:02

Re: Connection lost repeat error with "Nil" in it, please help

Post by davidcernat » 28 Apr 2020, 10:21

You don't need to do a fresh installation of TES3MP because there's probably nothing wrong with its saves and they're not affected much by disabling a mod.

You may need to do a fresh installation of the Morrowind folder that TES3MP loads its data files and assets from, assuming your problems really started only once you removed that mod.

Post Reply