Nub to modding OpenMW- making custom textures work.

Learn about OpenMW mod compatibility, check for problematic mods, discuss issues, and give us feedback about your experience with modded OpenMW.
Post Reply
User avatar
KittyBastetinati
Posts: 4
Joined: 26 Jul 2020, 16:17

Nub to modding OpenMW- making custom textures work.

Post by KittyBastetinati » 26 Jul 2020, 16:30

I love OpenMW. I think it's the best type of Morrowind. I've even developed a few of my own mods to run with it... Question though about uploading my own custom textures. I know OpenMW's textures don't work exactly the same as the other MW, I know enough to install other modders texture mods, but I don't know how to make my own texture mods work. Making custom nifs work in OpenMW was easy messing with Nifskope, but OpenbMWs textures I haven't wrapped my mind around yet.

A few things I like to retexture... Sometimes I'll creatively modify an existing texture in MW for example. My custom textures are nothing groundbreakingly photorealistic, just something I use for a few things out of personal preference. In regular MW my retextures work right off the bat, but in OpenMW I get the purple/pink missing texture bug. My method of retexturing is adding different textures to a mesh in Nifskope, and making sure the Meshes and Textures are in the proper directories. Can someone please tell me how to properly format and setup custom textures to operate with OpenMW? What error am I likely doing anyways?

My directory I use is SteamApps->Common->Morrowind->Data Files->Textures (Myh OpenMW folder is another directory). Baffling thing is other folks texture mods made for OpenMW seem to work there, and as I said, it's something I don't understand about textures in OpenMW cause my custom meshes work fine). Does it sound like file type? Or Directory? File name? Do I need a specific type of Nifskope to work together with OpenMW?

silentthief
Posts: 430
Joined: 18 Apr 2013, 01:20
Location: Currently traversing the Ascadian Isles

Re: Nub to modding OpenMW- making custom textures work.

Post by silentthief » 29 Jul 2020, 23:32

Can you give us more information? Such as what OS (windows, linux, mac) and version of OS you use? Can you provide the openmw logs?

ST
"You like to dance close to the fire, don't you?."

User avatar
KittyBastetinati
Posts: 4
Joined: 26 Jul 2020, 16:17

Re: Nub to modding OpenMW- making custom textures work.

Post by KittyBastetinati » 30 Jul 2020, 21:47

Ah yes I use Windows Ten. What happened was two different modding experiments which had unexpected results. One I tried to make Dwemer Aircraft, and the textures looked fine in both the CK and in regular game but in OpenMW they became bright pink blank textures. The other one I was experimenting with adding custom markings to the Khajiit body, and it looked almost perfect in both Nifskope, and the CK, but had a similar missing texture when it was run in OpenMW.

LoneWolf
Posts: 44
Joined: 26 Sep 2017, 19:13

Re: Nub to modding OpenMW- making custom textures work.

Post by LoneWolf » 31 Jul 2020, 18:31

but in OpenMW they became bright pink blank textures
That usually means openmw is unable to locate or use the texture.

This can have many causes* , check the openmw log file .
https://wiki.openmw.org/index.php?title=Paths incase you don't know where to find them.


*
one I encountered myself 2 or 3 versions back was with "better heads v2" .
In Textures/BH folder there are many files ending with .tga , OpenMW choked on those resulting in vampires with pink faces, orcs with faces without eyes and other weird stuff.

Converting the files from tga to dds solved those issues.

Post Reply