Page 1 of 1

How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 05:29
by sas647
First of all, hello everyone. Since I discovered OpenMW I never looked back at the original, it's truly incredible the amount of work put into it. Congrats to everyone who has worked on it!

Anyway, my question is, there is an armor mod I've always used in all my installations (http://www.theassimilationlab.com/forum ... c61a-9.jpg) but I can't get it to look right in OpenMW. I realize it uses the bumpmap hack from MCP and I already read and done as this handy guide says but it ends up looking dark and shiny (like this) while I want it to look like the last from the first screenshot. So, I'm wondering if I'm missing something or bump mapping on armor simply doesn't work yet on OpenMW :?: I'd greatly appreciate any advice, and thanks for your attention :mrgreen: .

Re: How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 07:55
by lysol
Please submit a link to the armor mod and I'll have a look at it.

Re: How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 12:36
by sas647
lysol wrote:
04 Jul 2018, 07:55
Please submit a link to the armor mod and I'll have a look at it.
Here it is: http://www.theassimilationlab.com/forum ... 2005_2012/

The author decided to compile all his armor mods into a single archove but the one in question is "Rev 5 Steel 1.2". If you want i can upload only that one.

Re: How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 17:17
by Starsheep
I didn't download the whole archive but have a look in your meshes: if you find a NiTextureEffect node with a CG_SPHERE_MAP reference that points to a glowmap texture, remove it. It makes stuff look overshiny in OpenMW

Re: How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 17:21
by AnyOldName3
You've tried following this, right?

https://openmw.readthedocs.io/en/master ... _mods.html

Re: How do I make this armor mod look right in OpenMW?

Posted: 04 Jul 2018, 18:55
by sas647
I went ahead and uploaded the mod I wanted only so anyone who cares can take a look easier: https://drive.google.com/open?id=1BQKd5 ... 3az8lWWiTl (disclaimer: I don't own this mod at all and in case there's a problem with me uploading a part of it without permission from the author, I'll remove it; just let me know)
AnyOldName3 wrote:
04 Jul 2018, 17:21
You've tried following this, right?

https://openmw.readthedocs.io/en/master ... _mods.html
Yes I did as I said on the OP, I deleted all the NiTextureEffects I could find on the models and changed the _nm's to _n, but all it did was make it look very dark and weird.
Starsheep wrote:
04 Jul 2018, 17:17
I didn't download the whole archive but have a look in your meshes: if you find a NiTextureEffect node with a CG_SPHERE_MAP reference that points to a glowmap texture, remove it. It makes stuff look overshiny in OpenMW
I'll try that when I get home, and post the results as soon as possible. Thanks everyone for chiming in, I really appreciate it!

EDIT: I couldn't find any "CG_SPHERE_MAP" refs in the models, so no luck there. I've played a bit with nifskope and pretty much all I managed to to was make the model look a little brighter and remove the gloss, but it still isn't rendering like it's supposed to. Bummer.

Re: How do I make this armor mod look right in OpenMW?

Posted: 08 Jul 2018, 23:31
by kuyondo
I have encountered this type of issue before. It has to do with the nif files. All i did was remove some blocks in nifskope, (or change somr parameters), and it worked. But i cant help on this particular nif file. Im not using a computer right now. Remove any block that are rrlated to bump maps, gloss maps,. Sometimes i did it using trial error method. Good luck

Re: How do I make this armor mod look right in OpenMW?

Posted: 09 Jul 2018, 04:50
by lysol
Sorry, I've been crazy busy the last days, and will unfortunately for a week more. I'll have a look later.